summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Krause2015-07-24 11:57:52 +0200
committerChristian Krause2015-07-24 11:57:52 +0200
commitb79a240026131a1dfb7906f2d84c23a9263bec60 (patch)
treee4c85a1cca46a9a1f98820e387fbf730c639b5e9
parent1679c389ce8e5ea9965e819c0dfe8193849fb722 (diff)
downloadaur-b79a240026131a1dfb7906f2d84c23a9263bec60.tar.gz
tophat-2.1.0-2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD24
-rw-r--r--fix_build_w_seqan1.4.patch23
3 files changed, 45 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44ed614e366c..65a142cead42 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,21 @@
pkgbase = tophat
pkgdesc = fast splice junction mapper for RNA-Seq reads
pkgver = 2.1.0
- pkgrel = 1
+ pkgrel = 2
url = http://ccb.jhu.edu/software/tophat/index.shtml
arch = x86_64
arch = i686
- license = BSL
+ license = custom
makedepends = boost
depends = boost-libs
depends = bowtie2
depends = python2
source = http://ccb.jhu.edu/software/tophat/downloads/tophat-2.1.0.tar.gz
+ source = https://github.com/seqan/seqan/archive/seqan-v1.4.2.tar.gz
+ source = fix_build_w_seqan1.4.patch
md5sums = 1ace6e96fa692af6ed885bad5fe7c4d7
+ md5sums = 7b0080b01feeb223e054dabef53d6fc5
+ md5sums = 93d47e54408b7b5eb4132d65f5dd5085
pkgname = tophat
diff --git a/PKGBUILD b/PKGBUILD
index 2505f698f67e..9b4876d624be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,19 @@
pkgname=tophat
pkgver=2.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="fast splice junction mapper for RNA-Seq reads"
arch=('x86_64' 'i686')
url="http://ccb.jhu.edu/software/tophat/index.shtml"
-license=('BSL')
+license=('custom')
depends=('boost-libs' 'bowtie2' 'python2')
makedepends=('boost')
-source=("http://ccb.jhu.edu/software/tophat/downloads/tophat-$pkgver.tar.gz")
-md5sums=('1ace6e96fa692af6ed885bad5fe7c4d7')
+source=("http://ccb.jhu.edu/software/tophat/downloads/tophat-$pkgver.tar.gz"
+ 'https://github.com/seqan/seqan/archive/seqan-v1.4.2.tar.gz'
+ 'fix_build_w_seqan1.4.patch')
+md5sums=('1ace6e96fa692af6ed885bad5fe7c4d7'
+ '7b0080b01feeb223e054dabef53d6fc5'
+ '93d47e54408b7b5eb4132d65f5dd5085')
prepare() {
cd $srcdir/$pkgname-$pkgver
@@ -30,16 +34,18 @@ prepare() {
src/tophat.py \
src/tophat-fusion-post
+ # fixes seqan issues
+ rm -rf src/SeqAn-1.3
+ patch -Np1 -i $srcdir/fix_build_w_seqan1.4.patch
+ sed -e "s|-I./SeqAn-1.3|-I$srcdir/seqan-seqan-v1.4.2/core/include|" \
+ -i configure.ac
+
autoreconf -fi
}
build() {
cd $srcdir/$pkgname-$pkgver
- export CC=clang
- export CXX=clang++
- export PYTHON=python2
-
./configure --prefix=/usr
# do not link against system-installed libbam.a
@@ -53,4 +59,6 @@ package() {
cd $srcdir/$pkgname-$pkgver
make DESTDIR=$pkgdir install
+
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
}
diff --git a/fix_build_w_seqan1.4.patch b/fix_build_w_seqan1.4.patch
new file mode 100644
index 000000000000..7ab7c5af4a78
--- /dev/null
+++ b/fix_build_w_seqan1.4.patch
@@ -0,0 +1,23 @@
+Description: Resolves build failure with seqan 1.4
+Bug-Closed: http://bugs.debian.org/733352
+Author: Manuel Holtgrewe <manuel.holtgrewe@fu-berlin.de>
+--- a/src/segment_juncs.cpp
++++ b/src/segment_juncs.cpp
+@@ -2050,10 +2050,13 @@ void juncs_from_ref_segs(RefSequenceTabl
+ typedef map<uint32_t, IntronMotifs> MotifMap;
+
+ MotifMap ims;
+-
+- seqan::DnaStringReverseComplement rev_donor_dinuc(donor_dinuc);
+- seqan::DnaStringReverseComplement rev_acceptor_dinuc(acceptor_dinuc);
+-
++
++ typedef seqan::ModifiedString<
++ seqan::ModifiedString<seqan::DnaString const, seqan::ModView<seqan::FunctorComplement<seqan::Dna> > >,
++ seqan::ModReverse> ConstDnaStringReverseComplement;
++ ConstDnaStringReverseComplement rev_donor_dinuc(donor_dinuc);
++ ConstDnaStringReverseComplement rev_acceptor_dinuc(acceptor_dinuc);
++
+ if (talkative)
+ fprintf(stderr, "Collecting potential splice sites in islands\n");
+