summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkmacleod2016-01-03 21:36:09 -0500
committerkmacleod2016-01-03 21:36:09 -0500
commit76ba125a03b5986b8b3ecb3e8ed11ce14c737292 (patch)
tree0974713ecbd7610b35145eecb85fc895f2ef9486
parentfdd81c5b2e3bc7e2673fec4fb1ff6292d233c858 (diff)
downloadaur-76ba125a03b5986b8b3ecb3e8ed11ce14c737292.tar.gz
Update to use python 3
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD10
2 files changed, 13 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 27d7f483eb32..9f65bdb1a140 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,16 @@
+# Generated by mksrcinfo v8
+# Mon Jan 4 01:41:23 UTC 2016
pkgbase = topydo-git
- pkgdesc = A couple of tools (actions, filters, sorting) for todo.txt files
- pkgver = 0.2.r0.g503d876
+ pkgdesc = topydo is a todo list application using the todo.txt format. It is heavily inspired by the todo.txt CLI by Gina Trapani.
+ pkgver = 0.9.r4.g19b5623
pkgrel = 1
url = https://github.com/bram85/topydo
arch = any
license = GPLv3
- depends = python2
+ depends = python
+ depends = python-setuptools
+ depends = python-six
+ depends = python-arrow
provides = topydo
source = git+https://github.com/bram85/topydo.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 4cd08953c78f..fe047a771086 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintener Théophane Hufschmitt <theophane.hufschmitt@gmx.fr>
pkgname=topydo-git
_gitname=topydo
-pkgver=0.2.r0.g503d876
+pkgver=0.9.r4.g19b5623
pkgrel=1
-pkgdesc="A couple of tools (actions, filters, sorting) for todo.txt files"
+pkgdesc="topydo is a todo list application using the todo.txt format. It is heavily inspired by the todo.txt CLI by Gina Trapani."
arch=("any")
url="https://github.com/bram85/topydo"
license=('GPLv3')
-depends=("python2" "python2-setuptools" "python2-six")
+depends=("python" "python-setuptools" "python-six" "python-arrow")
provides=("topydo")
source=("git+https://github.com/bram85/topydo.git")
md5sums=("SKIP")
@@ -19,6 +19,6 @@ pkgver() {
package() {
cd $srcdir/$_gitname
- python2 setup.py build
- python2 setup.py install --root=$pkgdir
+ python setup.py build
+ python setup.py install --root=$pkgdir
}