summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrufo2017-07-09 12:12:46 +0200
committergrufo2017-07-09 12:12:46 +0200
commitee9b0e517bbc055d7fda241e54f04f2751381bd6 (patch)
treef07a2bf673589383a9bf7a1d18d18c7402348415
parent138c3a10ee3253f193a514849e0a97f291c6f5f2 (diff)
downloadaur-ee9b0e517bbc055d7fda241e54f04f2751381bd6.tar.gz
tor-browser.install: code review
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
-rw-r--r--tor-browser.install5
3 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5690d437c304..0140873e4c05 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -36,7 +36,7 @@ pkgbase = tor-browser-en-us
source = tor-browser.sh
validpgpkeys = EF6E286DDA85EA2A4BA7DE684E2C6E8793298290
md5sums = 9178c9325979377f7ec57569b15fcb61
- md5sums = 80e4b01673024885aa2a505e795b0463
+ md5sums = b97eb146f24c15289d3b4518c0608c7e
md5sums = 494afbfa60fb4ce21840244cc3f7208c
md5sums = ac6ee6d201ae0fa14250fbaf13959130
source_i686 = https://dist.torproject.org/torbrowser/7.0.2/tor-browser-linux32-7.0.2_en-US.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 6f696c3764bc..28b9f1cb9087 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,8 @@
# gpg --keyserver hkp://pgp.mit.edu:11371 --recv-keys D1483FA6C3C07136
#
-# To port this PKGBUILD to another language of tor-browser you
-# have to change ONLY the variable ${_language} in PKGBUILD
+# To port this PKGBUILD to another language of tor-browser you have to
+# change ONLY the variable ${_language} in PKGBUILD and tor-browser.install
_language='en-US'
@@ -50,7 +50,7 @@ source=("${_pkgname}.desktop"
"${_pkgname}.sh")
md5sums=('9178c9325979377f7ec57569b15fcb61'
- '80e4b01673024885aa2a505e795b0463'
+ 'b97eb146f24c15289d3b4518c0608c7e'
'494afbfa60fb4ce21840244cc3f7208c'
'ac6ee6d201ae0fa14250fbaf13959130')
md5sums_i686=('SKIP'
diff --git a/tor-browser.install b/tor-browser.install
index 66b61985ac4f..0db07e14c886 100644
--- a/tor-browser.install
+++ b/tor-browser.install
@@ -1,4 +1,5 @@
pkgname='tor-browser'
+_language='en-US'
pre_install() {
echo
@@ -14,7 +15,7 @@ pre_install() {
post_install() {
echo
- echo "==> ${pkgname} will be extracted to ~/.${pkgname}"
+ echo "==> ${pkgname} will be extracted to ~/.${pkgname}-${_language,,}"
echo "==> the first time you run ${pkgname} as your normal user!"
echo "==> Just start it and have fun."
echo
@@ -33,6 +34,6 @@ post_remove() {
echo "==> You have to remove the tor-brower directory in your home"
echo "==> directory by hand: As your normal user, do:"
echo "==> "
- echo "==> rm -rf ~/.${pkgname}"
+ echo "==> rm -rf ~/.${pkgname}-${_language,,}"
echo
}