summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgrufo2019-01-30 00:45:24 +0000
committergrufo2019-01-30 00:45:24 +0000
commit9cf124708d57889d827eabb009d4f65500d943e5 (patch)
tree99047f455c72997e0e46eaafd8b7e90c2da83609
downloadaur-9cf124708d57889d827eabb009d4f65500d943e5.tar.gz
Initial commit
-rw-r--r--.SRCINFO50
-rw-r--r--PKGBUILD82
-rw-r--r--tor-browser.desktop8
-rw-r--r--tor-browser.install26
-rw-r--r--tor-browser.pngbin0 -> 13877 bytes
-rwxr-xr-xtor-browser.sh189
6 files changed, 355 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..503ad29ce929
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,50 @@
+pkgbase = tor-browser-sv-se
+ pkgdesc = Tor Browser Bundle: anonymous browsing using Firefox and Tor (sv-SE)
+ pkgver = 8.0.5
+ pkgrel = 1
+ url = https://www.torproject.org/projects/torbrowser.html
+ install = tor-browser.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gtk2
+ depends = mozilla-common
+ depends = libxt
+ depends = startup-notification
+ depends = mime-types
+ depends = dbus-glib
+ depends = alsa-lib
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ depends = libvpx
+ depends = icu
+ depends = libevent
+ depends = nss
+ depends = hunspell
+ depends = sqlite
+ optdepends = zenity: simple dialog boxes
+ optdepends = kdialog: KDE dialog boxes
+ optdepends = gst-plugins-good: H.264 video
+ optdepends = gst-libav: H.264 video
+ optdepends = libpulse: PulseAudio audio driver
+ optdepends = libnotify: Gnome dialog boxes
+ noextract = tor-browser-linux64-8.0.5_sv-SE.tar.xz
+ noextract = tor-browser-linux32-8.0.5_sv-SE.tar.xz
+ source = tor-browser.desktop
+ source = tor-browser.png
+ source = tor-browser.sh
+ validpgpkeys = EF6E286DDA85EA2A4BA7DE684E2C6E8793298290
+ sha256sums = e9b6620a5683b2df7878d35a087039bf4449eb8648361a12ddbd968d98b59e8b
+ sha256sums = 17fc2f5784d080233aca16e788d62ab6fe3e57cf781b123cfe32767de97d6d3b
+ sha256sums = 3a491ad1a476f2fb343f274eab4e8df925637438e6dac3591f092b3ef3294da3
+ source_i686 = https://dist.torproject.org/torbrowser/8.0.5/tor-browser-linux32-8.0.5_sv-SE.tar.xz
+ source_i686 = https://dist.torproject.org/torbrowser/8.0.5/tor-browser-linux32-8.0.5_sv-SE.tar.xz.asc
+ sha256sums_i686 = SKIP
+ sha256sums_i686 = SKIP
+ source_x86_64 = https://dist.torproject.org/torbrowser/8.0.5/tor-browser-linux64-8.0.5_sv-SE.tar.xz
+ source_x86_64 = https://dist.torproject.org/torbrowser/8.0.5/tor-browser-linux64-8.0.5_sv-SE.tar.xz.asc
+ sha256sums_x86_64 = SKIP
+ sha256sums_x86_64 = SKIP
+
+pkgname = tor-browser-sv-se
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9415ec409fb2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,82 @@
+# Maintainer: grufo <madmurphy333 AT gmail DOT com>
+# Contributor: midgard <arch.midgard AT janmaes DOT com>
+# Contributor: TrialnError <autumn-wind AT web DOT de>
+# Contributor: Yardena Cohen <yardenack AT gmail DOT com>
+# Contributor: Max Roder <maxroder AT web DOT de>
+# Contributor: Sebastian Jug <seb AT stianj DOT ug>
+
+#
+# Before running makepkg, you must do this:
+#
+# gpg --keyserver hkp://pgp.mit.edu:11371 --recv-keys 0x4E2C6E8793298290
+#
+
+# To port this PKGBUILD to another language of tor-browser you have to
+# change ONLY the variable ${_language} below
+
+_language='sv-SE'
+
+# This PKGBUILD is based on https://aur.archlinux.org/packages/tor-browser/
+
+_pkgname='tor-browser'
+pkgname="${_pkgname}-${_language,,}"
+pkgver='8.0.5'
+pkgrel='1'
+pkgdesc="Tor Browser Bundle: anonymous browsing using Firefox and Tor (${_language})"
+url='https://www.torproject.org/projects/torbrowser.html'
+arch=('i686' 'x86_64')
+_idstr32='linux32'
+_idstr64='linux64'
+license=('GPL')
+depends=('gtk2' 'mozilla-common' 'libxt' 'startup-notification' 'mime-types'
+ 'dbus-glib' 'alsa-lib' 'desktop-file-utils' 'hicolor-icon-theme'
+ 'libvpx' 'icu' 'libevent' 'nss' 'hunspell' 'sqlite')
+optdepends=('zenity: simple dialog boxes'
+ 'kdialog: KDE dialog boxes'
+ 'gst-plugins-good: H.264 video'
+ 'gst-libav: H.264 video'
+ 'libpulse: PulseAudio audio driver'
+ 'libnotify: Gnome dialog boxes')
+install="${_pkgname}.install"
+
+_archstr=$([[ "${CARCH}" == 'x86_64' ]] && echo -n "${_idstr64}" || echo -n "${_idstr32}")
+
+validpgpkeys=('EF6E286DDA85EA2A4BA7DE684E2C6E8793298290')
+
+source_i686=("https://dist.torproject.org/torbrowser/${pkgver}/${_pkgname}-${_idstr32}-${pkgver}_${_language}.tar.xz"{,.asc})
+source_x86_64=("https://dist.torproject.org/torbrowser/${pkgver}/${_pkgname}-${_idstr64}-${pkgver}_${_language}.tar.xz"{,.asc})
+source=("${_pkgname}.desktop"
+ "${_pkgname}.png"
+ "${_pkgname}.sh")
+
+sha256sums=('e9b6620a5683b2df7878d35a087039bf4449eb8648361a12ddbd968d98b59e8b'
+ '17fc2f5784d080233aca16e788d62ab6fe3e57cf781b123cfe32767de97d6d3b'
+ '3a491ad1a476f2fb343f274eab4e8df925637438e6dac3591f092b3ef3294da3')
+sha256sums_i686=('SKIP'
+ 'SKIP')
+sha256sums_x86_64=('SKIP'
+ 'SKIP')
+
+noextract=("${_pkgname}-${_idstr64}-${pkgver}_${_language}.tar.xz"
+ "${_pkgname}-${_idstr32}-${pkgver}_${_language}.tar.xz")
+
+package() {
+
+ cd "${srcdir}"
+
+ sed -i "s/__REPL_LANGUAGE__/${_language}/g" "${_pkgname}.desktop"
+ sed -i "s/__REPL_NAME__/${pkgname}/g" "${_pkgname}.desktop"
+
+ sed -i "s/__REPL_NAME__/${pkgname}/g" "${_pkgname}.sh"
+ sed -i "s/__REPL_VERSION__/${pkgver}/g" "${_pkgname}.sh"
+ sed -i "s/__REPL_RELEASE__/${pkgrel}/g" "${_pkgname}.sh"
+ sed -i "s/__REPL_LANGUAGE__/${_language}/g" "${_pkgname}.sh"
+ sed -i "s/__REPL_ARCH__/${_archstr}/g" "${_pkgname}.sh"
+
+ install -Dm 644 "${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm 644 "${_pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm 755 "${_pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
+
+ install -Dm 644 "${_pkgname}-${_archstr}-${pkgver}_${_language}.tar.xz" "${pkgdir}/opt/${pkgname}/${_pkgname}-${_archstr}-${pkgver}_${_language}.tar.xz"
+
+}
diff --git a/tor-browser.desktop b/tor-browser.desktop
new file mode 100644
index 000000000000..709ba97c378e
--- /dev/null
+++ b/tor-browser.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Name=Tor Browser (__REPL_LANGUAGE__)
+Exec=/usr/bin/__REPL_NAME__
+Icon=__REPL_NAME__
+Categories=Network;
+Comment=Anonymous browsing using Firefox and Tor
diff --git a/tor-browser.install b/tor-browser.install
new file mode 100644
index 000000000000..5317164af9b0
--- /dev/null
+++ b/tor-browser.install
@@ -0,0 +1,26 @@
+pkgname='tor-browser'
+
+post_install() {
+ echo
+ echo "==> ${pkgname} will be extracted to ~/.${pkgname}"
+ echo "==> the first time you run ${pkgname} as your normal user!"
+ echo "==> Just start it and have fun."
+ echo
+}
+
+post_upgrade() {
+ echo
+ echo "==> The ${pkgname} copy in your home directory will be upgraded at the"
+ echo "==> first time you run it as your normal user!"
+ echo "==> Just start and have fun."
+ echo
+}
+
+post_remove() {
+ echo
+ echo "==> You have to remove the tor-brower directory in your home"
+ echo "==> directory by hand: As your normal user, do:"
+ echo "==> "
+ echo "==> rm -rf ~/.${pkgname}"
+ echo
+}
diff --git a/tor-browser.png b/tor-browser.png
new file mode 100644
index 000000000000..39c4ab220c25
--- /dev/null
+++ b/tor-browser.png
Binary files differ
diff --git a/tor-browser.sh b/tor-browser.sh
new file mode 100755
index 000000000000..6e14ef0a6794
--- /dev/null
+++ b/tor-browser.sh
@@ -0,0 +1,189 @@
+#!/usr/bin/env bash
+
+# Copyright (C) 2009 Benjamin Drung <bdrung at ubuntu dot com>
+# Copyright (C) 2012 Alessio Sergi <al3hex at gmail dot com>
+# Copyright (C) 2017 grufo <madmurphy333 at gmail dot com> (Arch User Repository version)
+# modified 2012 for tor-browser (Max Roder <maxroder at web dot de>)
+# modified 2014 by Yardena Cohen <yardenack at gmail dot com>
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+set -e
+
+
+# filled by PKGBUILD
+_TB_PKGNAME_='__REPL_NAME__'
+_TB_VERSION_='__REPL_VERSION__'
+_TB_RELEASE_='__REPL_RELEASE__'
+_TB_LANGUAGE_="__REPL_LANGUAGE__"
+_TB_ARCH_='__REPL_ARCH__'
+
+# other constants and variables
+_TB_HOME_DIR_=~/".${_TB_PKGNAME_}"
+_TB_VER_FILE_="${_TB_HOME_DIR_}/VERSION"
+_TB_LOG_FILE_="${_TB_HOME_DIR_}/LOG"
+_TB_APP_DIR_="${_TB_HOME_DIR_}/app"
+_TB_REFRESH_=0
+
+
+# syntax: _notify_ "${TITLE}" "${MESSAGE}"
+_notify_() {
+
+ if [ $(which zenity 2>/dev/null) ]; then
+ zenity --info --title "${1}" --text "${2}"
+ elif [ $(which notify-send 2>/dev/null) ]; then
+ notify-send "${1}" "${2}"
+ elif [ $(which kdialog 2>/dev/null) ]; then
+ kdialog --title "${1}" --passivepopup "${2}"
+ else
+ echo -e "${0}: [${1}] ${2}" >&2
+ fi
+
+}
+
+
+# syntax: _compare_ver_ "${INSTALLED_VERSION}" "${LATEST_VERSION}"
+_compare_ver_() {
+
+ [[ "${1}" == "${2}" ]] && return 1 || [[ "${1}" == "`echo -e "${1}\n${2}" | sort -V | head -n1`" ]]
+
+}
+
+
+_refresh_local_() {
+
+ local KEEP_DIR="${_TB_APP_DIR_}/Browser/TorBrowser/Data/Browser"
+ local KEPT_DIR=~/".${_TB_PKGNAME_}-tmpdata"
+ local DIR_IS_KEPT=0
+
+ if [[ -d "${KEEP_DIR}" ]]; then
+ [[ -d "${KEPT_DIR}" ]] && rm -rf "${KEPT_DIR}"
+ mv "${KEEP_DIR}" "${KEPT_DIR}"
+ echo "${0}: Preserving files in ${KEPT_DIR}/." >> "${_TB_LOG_FILE_}"
+ DIR_IS_KEPT=1
+ fi
+
+ echo "${0}: Extracting files to ${_TB_APP_DIR_}." >> "${_TB_LOG_FILE_}"
+ rm -rf "${_TB_APP_DIR_}"/*
+ tar --strip-components=1 -xJf "/opt/${_TB_PKGNAME_}/tor-browser-${_TB_ARCH_}-${_TB_VERSION_}_${_TB_LANGUAGE_}.tar.xz" \
+ -C "${_TB_APP_DIR_}" >> "${_TB_LOG_FILE_}" 2>&1 || _notify_ 'Error' \
+ "The tor-browser archive could not be extracted to your home directory. \
+ \nCheck permissions of ${_TB_APP_DIR_}. \
+ \nThe error log can be found in ${_TB_LOG_FILE_}."
+
+ if [[ ! ${DIR_IS_KEPT} -eq 0 ]]; then
+ rm -rf "${KEEP_DIR}"
+ mv "${KEPT_DIR}" "${KEEP_DIR}"
+ fi
+
+ [[ -f "${_TB_APP_DIR_}/Browser/start-tor-browser" ]] && echo "${_TB_VERSION_}" > "${_TB_VER_FILE_}"
+
+}
+
+
+_aur_update_() {
+
+ if [[ "$(id -u)" == '0' ]]; then
+ echo 'It is not a good idea to do this as root. Abort.' 1>&2
+ exit 1
+ fi
+
+ local DO_UPDATE=0
+ local TMP_PKGBUILD="$(mktemp -d)"
+
+ cd "${TMP_PKGBUILD}"
+
+ if ! { curl --silent --fail "https://aur.archlinux.org/cgit/aur.git/snapshot/${_TB_PKGNAME_}.tar.gz" | tar xz ;} 2>/dev/null; then
+ echo 'Unable to retrieve the PKGBUILD. Abort.' 1>&2
+ rm -rf "${TMP_PKGBUILD}"
+ exit 1
+ fi
+
+ cd "${TMP_PKGBUILD}/${_TB_PKGNAME_}"
+
+ local AUR_VERSION="$(grep 'pkgver' '.SRCINFO' | cut -d = -f2 | sed -e 's/^[[:space:]]*//')"
+ local AUR_RELEASE="$(grep 'pkgrel' '.SRCINFO' | cut -d = -f2 | sed -e 's/^[[:space:]]*//')"
+
+ if _compare_ver_ "${_TB_VERSION_}" "${AUR_VERSION}"; then
+ echo "Found new version (${_TB_VERSION_} -> ${AUR_VERSION})..."
+ DO_UPDATE=1
+ elif [[ "${_TB_VERSION_}" == "${AUR_VERSION}" ]] && [[ "${_TB_RELEASE_}" != "${AUR_RELEASE}" ]] && [[ "${_TB_RELEASE_}" == "`echo -e "${_TB_RELEASE_}\n${AUR_RELEASE}" | sort | head -n1`" ]]; then
+ echo 'Found new PKGBUILD...'
+ DO_UPDATE=1
+ else
+ echo "Everything is up to date (current version: ${_TB_VERSION_})."
+ fi
+
+ [[ ! ${DO_UPDATE} -eq 0 ]] && makepkg -si
+
+ rm -rf "${TMP_PKGBUILD}"
+
+}
+
+
+_usage_() {
+
+ cat <<EOF
+Usage: ${0##*/} [option]
+
+Options:
+ -h|--help Show this help message and exit
+ -u|--update Search in AUR for a new release and install it
+ -r|--refresh Refresh the copy in your home directory and launch tor-browser
+ -e|--erase Erase the copy in your home directory
+ --dir=<directory> The Tor-Browser directory to use
+
+ All unrecognized arguments will be passed to the browser.
+EOF
+
+}
+
+
+args=()
+for arg; do
+ case "${arg}" in
+ -h|--help) _usage_; exit 0 ;;
+ -u|--update) _aur_update_; exit 0 ;;
+ -f|--refresh) _TB_REFRESH_=1 ;;
+ -e|--erase) rm -rf "${_TB_HOME_DIR_}"; exit 0 ;;
+ --dir=*) _TB_HOME_DIR_="${arg#*=}" ;;
+ *) args+=("$arg") ;;
+ esac
+done
+
+# create directory, if it is missing (e.g. first run)
+[[ ! -d "${_TB_APP_DIR_}" ]] && mkdir -p "${_TB_APP_DIR_}"
+cd "${_TB_HOME_DIR_}"
+
+# create version file if missing
+[[ ! -f "${_TB_VER_FILE_}" ]] && echo 0 > "${_TB_VER_FILE_}"
+
+# get the installed version
+while read _TB_VER_LINE_
+do
+ _TB_INSTALLED_VERSION_="${_TB_VER_LINE_}"
+done < "${_TB_VER_FILE_}"
+
+# start update if old or no tor-browser is installed
+if [[ "${_TB_INSTALLED_VERSION_}" == "${_TB_VERSION_}" ]] && [[ ${_TB_REFRESH_} -eq 0 ]]; then
+ # clear log
+ > "${_TB_LOG_FILE_}"
+else
+ echo "${0}: Your version in ${_TB_HOME_DIR_} is outdated or you do not have installed ${_TB_PKGNAME_} yet." > "${_TB_LOG_FILE_}"
+ _refresh_local_
+fi
+
+# start tor-browser
+"${_TB_APP_DIR_}/Browser/start-tor-browser" "${args[@]}"
+