summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYour Name2019-02-16 22:48:04 -0500
committerYour Name2019-02-16 22:48:04 -0500
commit4f4ddd00821b9dc26e375421a83413b0e01506dd (patch)
tree5b40eaed449d6a55fc4d13c421b1cbf07d91ddee
parentdab5ee82dd592ee0e2b8c6e18ab7436c90a8700a (diff)
downloadaur-4f4ddd00821b9dc26e375421a83413b0e01506dd.tar.gz
add config for transparent proxying
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--transparent_proxy21
3 files changed, 27 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 94b3d3e81a05..ccaa93d3f58c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Wed Feb 13 10:07:14 UTC 2019
+# Sun Feb 17 03:48:02 UTC 2019
pkgbase = tor-git
pkgdesc = An anonymizing overlay network (development version)
pkgver = 0.4.0.1.alpha.31346
@@ -23,6 +23,7 @@ pkgbase = tor-git
backup = etc/tor/torrc.d
source = git+https://git.torproject.org/tor.git#branch=master
source = nodes
+ source = transparent_proxy
source = torrc
source = tor.logrotate
source = tor.service
@@ -30,6 +31,7 @@ pkgbase = tor-git
source = tor.sysusers
sha256sums = SKIP
sha256sums = eb82c6eaef6cd2e9451b4096f4ce23b3ee91fc408cdebd3280698cbe1a3b7ca1
+ sha256sums = 7fbb63e9411eee2176964449a3d6809d16e1120152c6ff201ecea1d1f97f102b
sha256sums = 5e40baff0e6cdc487793453ab06155c2974cc8bb20096db98be641fcceccd328
sha256sums = d447227fcc2756778a1be143b8975d67b25ea15688cde2291185b3c71d0f6e34
sha256sums = 7f98569aefffead72e8712c1ad27de3fc2095575da003691b2513ca54042efbb
diff --git a/PKGBUILD b/PKGBUILD
index 9bded07a6052..1ce984393367 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -33,11 +33,12 @@ backup=('etc/tor/torrc'
}
source=("git+https://git.torproject.org/tor.git#branch=${_branch:-master}"
- 'nodes' 'torrc' 'tor.logrotate'
+ 'nodes' 'transparent_proxy' 'torrc' 'tor.logrotate'
'tor.service' 'tor.tmpfiles' 'tor.sysusers')
sha256sums=('SKIP'
'eb82c6eaef6cd2e9451b4096f4ce23b3ee91fc408cdebd3280698cbe1a3b7ca1'
+ '7fbb63e9411eee2176964449a3d6809d16e1120152c6ff201ecea1d1f97f102b'
'5e40baff0e6cdc487793453ab06155c2974cc8bb20096db98be641fcceccd328'
'd447227fcc2756778a1be143b8975d67b25ea15688cde2291185b3c71d0f6e34'
'7f98569aefffead72e8712c1ad27de3fc2095575da003691b2513ca54042efbb'
@@ -87,5 +88,6 @@ package() {
install -Dm644 "$srcdir/tor.sysusers" "$pkgdir/usr/lib/sysusers.d/tor.conf"
install -Dm644 "$srcdir/tor.logrotate" "$pkgdir/etc/logrotate.d/tor"
install -Dm644 "$srcdir/nodes" "$pkgdir/etc/tor/torrc.d/nodes"
+ install -Dm644 "$srcdir/transparent_proxy" "$pkgdir/etc/tor/torrc.d/transparent_proxy"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/tor/LICENSE"
}
diff --git a/transparent_proxy b/transparent_proxy
new file mode 100644
index 000000000000..4db96cb2575e
--- /dev/null
+++ b/transparent_proxy
@@ -0,0 +1,21 @@
+## https://trac.torproject.org/projects/tor/wiki/doc/TransparentProxy
+
+#VirtualAddrNetworkIPv4 10.192.0.0/10
+#AutomapHostsOnResolve 1
+
+## TransPort [address:]port|auto [isolation flags]
+##
+## Open this port to listen for transparent proxy connections.
+## Set this to 0 if you don’t want to allow transparent proxy connections.
+## Set the port to "auto" to have Tor pick a port for you. This directive
+## can be specified multiple times to bind to multiple addresses/ports.
+#TransPort 127.0.0.1:9040 IsolateClientAddr IsolateClientProtocol IsolateDestAddr IsolateDestPort
+
+## DNSPort [address:]port|auto [isolation flags]
+##
+## If non-zero, open this port to listen for UDP DNS requests, and
+## resolve them anonymously. This port only handles A, AAAA, and PTR
+## requests---it doesn’t handle arbitrary DNS request types. Set the port
+## to "auto" to have Tor pick a port for you.
+## This directive can be specified multiple times to bind to multiple addresses/ports.
+#DNSPort 127.0.0.1:53