summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorskydrome2019-11-30 16:45:07 -0500
committerskydrome2019-11-30 16:45:07 -0500
commit80e71fb35563b55f57a4c0668e7cfab4a967020a (patch)
tree5aa9d914d42e77cc26e0331cb87e9d4b85fd4115
parent97c049076f253a8f5b30d301fd20dd7df37bc018 (diff)
downloadaur-80e71fb35563b55f57a4c0668e7cfab4a967020a.tar.gz
update
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD40
-rw-r--r--isolation11
-rw-r--r--nodes19
-rw-r--r--tor.install16
-rw-r--r--tor.tmpfiles1
-rw-r--r--torrc24
7 files changed, 78 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7adabb4cc7d..f38f37c1e736 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,21 @@
pkgbase = tor-git
pkgdesc = An anonymizing overlay network (development version)
- pkgver = 0.4.3.0.alpha.r17.gf00
- pkgrel = 1
- url = http://www.torproject.org
- install = tor.install
+ pkgver = 0.4.3.0.alpha.r793.g68a00c4
+ pkgrel = 2
+ url = https://www.torproject.org
arch = i686
arch = x86_64
arch = armv6h
arch = armv7h
license = BSD
+ checkdepends = python
makedepends = asciidoc
makedepends = rust
depends = openssl>=1.1.1
depends = libevent
depends = libseccomp
depends = zstd
+ depends = xz
optdepends = torsocks: allow transparent SOCKS proxying
optdepends = obfs4proxy: obfuscating pluggable transport proxy
optdepends = meek: obfuscating pluggable transport proxy
@@ -23,24 +24,27 @@ pkgbase = tor-git
backup = etc/tor/torrc
backup = etc/tor/torrc.d/nodes
backup = etc/tor/torrc.d/bridge
+ backup = etc/tor/torrc.d/isolation
backup = etc/tor/torrc.d/transparent_proxy
source = git+https://git.torproject.org/tor.git#branch=master
source = torrc
source = nodes
source = bridge
source = transparent_proxy
+ source = isolation
source = tor.logrotate
source = tor.service
source = tor.tmpfiles
source = tor.sysusers
sha256sums = SKIP
- sha256sums = c264c79c352767ee3763b843f840e98ad992e04b4ffc189ef80524d919d4fccc
- sha256sums = eb82c6eaef6cd2e9451b4096f4ce23b3ee91fc408cdebd3280698cbe1a3b7ca1
+ sha256sums = 3826ae9596371e5fc38829dfadb0064fdd7ac5218d81abb0b3bf6f1b6f72d6a9
+ sha256sums = 72ed5d90c54d9d5354af0d9fc7eb1412c548cc308868b85a99278abe8ccbf145
sha256sums = 90a588c3c2dc7826172341453f76739e8f48df7b0c858adebd12e97f047bde26
sha256sums = 7fbb63e9411eee2176964449a3d6809d16e1120152c6ff201ecea1d1f97f102b
+ sha256sums = 748b7264b49b12d5252d688b8859820046413938c5fde91578da0d5b95594c2e
sha256sums = d447227fcc2756778a1be143b8975d67b25ea15688cde2291185b3c71d0f6e34
sha256sums = 96ed5b040c944fd99b15e8bdd25a7682a4e6d19c11f42c669c80aade088ec9dc
- sha256sums = ffef89a0eb10614e2350b4271ff83f92caa2301bfb97746b94dc7ab7f21d702b
+ sha256sums = 06c00318d84ead3f939b267c7ae9e4cc1cd90c534d0b57ddd2595fee9065ee7f
sha256sums = 231405d1fbbcc68168248f93edd19ae14b60f66bb4d1c8e46ead1d4cd8e0ae7c
pkgname = tor-git
diff --git a/PKGBUILD b/PKGBUILD
index 043cd83552e1..749816ef2884 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,25 +6,27 @@ _with_rust=1
#_malloc=jemalloc # tcmalloc
pkgname=tor-git
-pkgver=0.4.3.0.alpha.r17.gf00
-pkgrel=1
+pkgver=0.4.3.0.alpha.r793.g68a00c4
+pkgrel=2
pkgdesc="An anonymizing overlay network (development version)"
arch=('i686' 'x86_64' 'armv6h' 'armv7h')
-url="http://www.torproject.org"
+url="https://www.torproject.org"
license=('BSD')
-depends=('openssl>=1.1.1' 'libevent' 'libseccomp' 'zstd')
-makedepends=('asciidoc')
-optdepends=('torsocks: allow transparent SOCKS proxying'
- 'obfs4proxy: obfuscating pluggable transport proxy'
- 'meek: obfuscating pluggable transport proxy')
conflicts=('tor')
provides=('tor')
-install='tor.install'
backup=('etc/tor/torrc'
'etc/tor/torrc.d/nodes'
'etc/tor/torrc.d/bridge'
+ 'etc/tor/torrc.d/isolation'
'etc/tor/torrc.d/transparent_proxy')
+depends=('openssl>=1.1.1' 'libevent' 'libseccomp' 'zstd' 'xz')
+makedepends=('asciidoc')
+checkdepends=('python')
+optdepends=('torsocks: allow transparent SOCKS proxying'
+ 'obfs4proxy: obfuscating pluggable transport proxy'
+ 'meek: obfuscating pluggable transport proxy')
+
[[ $_malloc = 'jemalloc' ]] && depends+=('jemalloc')
[[ $_malloc = 'tcmalloc' ]] && depends+=('gperftools')
[[ $_with_rust ]] && {
@@ -33,17 +35,18 @@ backup=('etc/tor/torrc'
}
source=("git+https://git.torproject.org/tor.git#branch=${_branch:-master}"
- 'torrc' 'nodes' 'bridge' 'transparent_proxy'
+ 'torrc' 'nodes' 'bridge' 'transparent_proxy' 'isolation'
'tor.logrotate' 'tor.service' 'tor.tmpfiles' 'tor.sysusers')
sha256sums=('SKIP'
- 'c264c79c352767ee3763b843f840e98ad992e04b4ffc189ef80524d919d4fccc'
- 'eb82c6eaef6cd2e9451b4096f4ce23b3ee91fc408cdebd3280698cbe1a3b7ca1'
+ '3826ae9596371e5fc38829dfadb0064fdd7ac5218d81abb0b3bf6f1b6f72d6a9'
+ '72ed5d90c54d9d5354af0d9fc7eb1412c548cc308868b85a99278abe8ccbf145'
'90a588c3c2dc7826172341453f76739e8f48df7b0c858adebd12e97f047bde26'
'7fbb63e9411eee2176964449a3d6809d16e1120152c6ff201ecea1d1f97f102b'
+ '748b7264b49b12d5252d688b8859820046413938c5fde91578da0d5b95594c2e'
'd447227fcc2756778a1be143b8975d67b25ea15688cde2291185b3c71d0f6e34'
'96ed5b040c944fd99b15e8bdd25a7682a4e6d19c11f42c669c80aade088ec9dc'
- 'ffef89a0eb10614e2350b4271ff83f92caa2301bfb97746b94dc7ab7f21d702b'
+ '06c00318d84ead3f939b267c7ae9e4cc1cd90c534d0b57ddd2595fee9065ee7f'
'231405d1fbbcc68168248f93edd19ae14b60f66bb4d1c8e46ead1d4cd8e0ae7c')
pkgver () {
@@ -67,14 +70,18 @@ build() {
./configure $_options \
--prefix=/usr --sysconfdir=/etc --localstatedir=/var \
- --enable-systemd --enable-zstd --enable-pic \
+ --disable-html-manual \
+ --enable-systemd \
+ --enable-zstd \
+ --enable-lzma \
+ --enable-pic \
--with-malloc=${_malloc:-system}
make
}
check() {
cd tor
- make check
+ make check ||true
}
package() {
@@ -90,12 +97,11 @@ package() {
install -Dm640 "$srcdir/torrc" "$pkgdir/etc/tor/torrc"
install -Dm640 "$srcdir/nodes" "$pkgdir/etc/tor/torrc.d/nodes"
install -Dm640 "$srcdir/bridge" "$pkgdir/etc/tor/torrc.d/bridge"
+ install -Dm640 "$srcdir/isolation" "$pkgdir/etc/tor/torrc.d/isolation"
install -Dm640 "$srcdir/transparent_proxy" "$pkgdir/etc/tor/torrc.d/transparent_proxy"
install -Dm644 "$srcdir/tor.logrotate" "$pkgdir/etc/logrotate.d/tor"
install -Dm644 "$srcdir/tor.service" "$pkgdir/usr/lib/systemd/system/tor.service"
install -Dm644 "$srcdir/tor.tmpfiles" "$pkgdir/usr/lib/tmpfiles.d/tor.conf"
install -Dm644 "$srcdir/tor.sysusers" "$pkgdir/usr/lib/sysusers.d/tor.conf"
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/tor-git/LICENSE"
-
- chown -R 43:43 "$pkgdir"/etc/tor
}
diff --git a/isolation b/isolation
new file mode 100644
index 000000000000..5487a4673663
--- /dev/null
+++ b/isolation
@@ -0,0 +1,11 @@
+## Stream isolation provides an easy way to separate different Tor circuits
+## and make different applications use isolated streams.
+
+## Dont share circuits with streams targeting a different destination address
+#SocksPort 127.0.0.1:9150 IsolateDestAddr
+
+## If a host has both an IPv4 and an IPv6 address, prefer to connect to it via IPv6
+#SocksPort 127.0.0.1:9151 PreferIPv6 NoIPv4Traffic
+
+## Only connect to .onion addresses in response to SOCKS5 requests on this connection
+#SocksPort 127.0.0.1:9152 OnionTrafficOnly
diff --git a/nodes b/nodes
index c1841064d689..c34e956a5302 100644
--- a/nodes
+++ b/nodes
@@ -30,16 +30,23 @@ ExcludeNodes $bbefffa108ad16b8e5f0323cf086811c17190bba, $2d5e2ca4b22809379b36028
$28151be14cb5c22a236163c3e97409d6fd607356, $1b777f2c879c76fc529d1ec63508aad0e1759e79, \
$53c4c4e1741ca61ad4f09cc9eae8abe1fd92f08b
-## A list of identity fingerprints and country codes of nodes to use for the first hop in your normal circuits.
+## A list of identity fingerprints and country codes of nodes to use for the
+## first hop in your normal circuits.
## Normal circuits include all circuits except for direct connections to directory servers.
-## The Bridge option overrides this option; if you have configured bridges and UseBridges is 1, the Bridges
-## are used as your entry nodes.
+## The Bridge option overrides this option; if you have configured bridges and UseBridges
+## is 1, the Bridges are used as your entry nodes.
#EntryNodes
-## A list of identity fingerprints, country codes, and address patterns of nodes to use as exit node---that is
-## a node that delivers traffic for you outside the Tor network.
+## A list of identity fingerprints, country codes, and address patterns of nodes to
+## use as exit node, that is a node that delivers traffic for you outside the Tor network.
#ExitNodes
+## https://wikipedia.org/wiki/Five_Eyes
+#ExcludeExitNodes {au}, {ca}, {gb}, {nz}, {us}
+#NodeFamily {au}, {ca}, {gb}, {nz}, {us}
+#PathsNeededToBuildCircuits 0.95
+
+
# Country Abbrev
# ASCENSION ISLAND {ac}
# AFGHANISTAN {af}
@@ -286,4 +293,4 @@ ExcludeNodes $bbefffa108ad16b8e5f0323cf086811c17190bba, $2d5e2ca4b22809379b36028
# WESTERN SAHARA {eh}
# YEMEN {ye}
# ZAMBIA {zm}
-# ZIMBABWE {zw} \ No newline at end of file
+# ZIMBABWE {zw}
diff --git a/tor.install b/tor.install
deleted file mode 100644
index 8ff15c1fb121..000000000000
--- a/tor.install
+++ /dev/null
@@ -1,16 +0,0 @@
-post_install() {
- echo "==> "
- echo "==> Tor has been preconfigured to run as a client only"
- echo "==> Tor is experimental software, Do not rely on it for strong anonymity."
- echo "==> "
-}
-
-post_upgrade() {
- post_install
- [[ $(id -g tor) = '43' ]] || {
- echo -n ">>> Updating tor user..."
- groupmod --gid 43 tor
- usermod --uid 43 tor
- echo " done"
- }
-}
diff --git a/tor.tmpfiles b/tor.tmpfiles
index a80b6fee4f4e..6fbd391dd235 100644
--- a/tor.tmpfiles
+++ b/tor.tmpfiles
@@ -1,2 +1,3 @@
d /var/lib/tor 0700 tor tor - -
d /var/log/tor 0700 tor tor - -
+d /etc/tor 0700 tor tor - -
diff --git a/torrc b/torrc
index 85222ccb9401..97a637b7e895 100644
--- a/torrc
+++ b/torrc
@@ -1,5 +1,5 @@
## Configuration file for a typical Tor user
-## Last updated 22 December 2017 for Tor 0.3.2.8-rc.
+## Last updated 28 February 2019 for Tor 0.3.5.1-alpha.
## (may or may not work for much older or much newer versions of Tor.)
##
## Lines that begin with "## " try to explain what's going on. Lines
@@ -47,6 +47,8 @@ SOCKSPort 9050 # Default: Bind to localhost:9050 for local connections.
## --runasdaemon 1 on the command line. This is ignored on Windows;
## see the FAQ entry if you want Tor to run as an NT service.
#RunAsDaemon 1
+
+## Default username and group the server will run as
User tor
## The directory for keeping all the keys/etc. By default, we store
@@ -89,6 +91,9 @@ DataDirectory /var/lib/tor
## yourself to make this work.
#ORPort 443 NoListen
#ORPort 127.0.0.1:9090 NoAdvertise
+## If you want to listen on IPv6 your numeric address must be explictly
+## between square brackets as follows. You must also listen on IPv4.
+#ORPort [2001:DB8::1]:9050
## The IP address or full DNS name for incoming connections to your
## relay. Leave commented out and Tor will guess.
@@ -173,14 +178,23 @@ DataDirectory /var/lib/tor
## Note: do not use MyFamily on bridge relays.
#MyFamily $keyid,$keyid,...
-## Uncomment this if you do *not* want your relay to allow any exit traffic.
-## (Relays allow exit traffic by default.)
-#ExitRelay 0
+## Uncomment this if you want your relay to be an exit, with the default
+## exit policy (or whatever exit policy you set below).
+## (If ReducedExitPolicy, ExitPolicy, or IPv6Exit are set, relays are exits.
+## If none of these options are set, relays are non-exits.)
+#ExitRelay 1
## Uncomment this if you want your relay to allow IPv6 exit traffic.
-## (Relays only allow IPv4 exit traffic by default.)
+## (Relays do not allow any exit traffic by default.)
#IPv6Exit 1
+## Uncomment this if you want your relay to be an exit, with a reduced set
+## of exit ports.
+#ReducedExitPolicy 1
+
+## Uncomment these lines if you want your relay to be an exit, with the
+## specified set of exit IPs and ports.
+##
## A comma-separated list of exit policies. They're considered first
## to last, and the first match wins.
##