summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduard Tolosa2023-04-15 19:21:56 -0500
committerEduard Tolosa2023-04-15 19:21:56 -0500
commit1c51d02cb646c7330fead431420fd14f988a19eb (patch)
tree87c386eccf1cd3e4949e8c1483974e65b1367c62
parentef5ddae67d29fe3bc011392650f72c57548d3aa0 (diff)
downloadaur-1c51d02cb646c7330fead431420fd14f988a19eb.tar.gz
Bump package.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD7
-rw-r--r--tor-router.install7
3 files changed, 11 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 99b694b40f53..9ee2820c46b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tor-router
pkgdesc = A tool that allow you to make TOR your default gateway and send all internet connections under TOR (as transparent proxy) for increase privacy/anonymity without extra unnecessary code.
- pkgver = 1.4.1
+ pkgver = 1.5.0
pkgrel = 1
url = https://github.com/edu4rdshl/tor-router
install = tor-router.install
@@ -9,10 +9,9 @@ pkgbase = tor-router
depends = tor
depends = systemd
optdepends = curl: to verify if the script run sucessfully.
- source = https://github.com/Edu4rdSHL/tor-router/archive/1.4.1.tar.gz
+ source = https://github.com/Edu4rdSHL/tor-router/archive/1.5.0.tar.gz
source = tor-router.install
- sha512sums = 5a04a3496b7618cd7f30825651cbfbd71027823961c2a46c0a653150abcbc35a9631ad2db01fe279577e157bee86e4fe0f5c31a15de6b1cbc141fbac1b9def3d
- sha512sums = 2a0393f2f2c5603b3c9f59c14510121a2e57392b701ba5be9336bd93624ff4e6e50d2338a4f0eeadf07ad1d0d50d8646d1418e418b593baea09a418f9972fac1
+ sha512sums = d0c53877d3ad3a3380bee2821708e1956e89d2adabd5a678c475d2090b8378cda7a587e5c1f022d41ec2e37240ba9fe256ef449b653c65e0579f2967171f8791
+ sha512sums = 043ae270b9153a8115f46058e369f2d461a5f34891264eed1a5daad444bb15210fd4c6a35b6cfc1c531e378d1fb7e238079baddc2b6e299c60360ec91e61718f
pkgname = tor-router
-
diff --git a/PKGBUILD b/PKGBUILD
index 3137c22f6e00..120a6243ae43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: edu4rdshl
pkgname=tor-router
-pkgver=1.4.1
+pkgver=1.5.0
pkgrel=1
pkgdesc='A tool that allow you to make TOR your default gateway and send all internet connections under TOR (as transparent proxy) for increase privacy/anonymity without extra unnecessary code.'
arch=('any')
@@ -12,9 +12,8 @@ optdepends=('curl: to verify if the script run sucessfully.')
install=tor-router.install
source=("https://github.com/Edu4rdSHL/tor-router/archive/$pkgver.tar.gz"
'tor-router.install')
-sha512sums=('5a04a3496b7618cd7f30825651cbfbd71027823961c2a46c0a653150abcbc35a9631ad2db01fe279577e157bee86e4fe0f5c31a15de6b1cbc141fbac1b9def3d'
- '2a0393f2f2c5603b3c9f59c14510121a2e57392b701ba5be9336bd93624ff4e6e50d2338a4f0eeadf07ad1d0d50d8646d1418e418b593baea09a418f9972fac1'
- )
+sha512sums=('d0c53877d3ad3a3380bee2821708e1956e89d2adabd5a678c475d2090b8378cda7a587e5c1f022d41ec2e37240ba9fe256ef449b653c65e0579f2967171f8791'
+ '043ae270b9153a8115f46058e369f2d461a5f34891264eed1a5daad444bb15210fd4c6a35b6cfc1c531e378d1fb7e238079baddc2b6e299c60360ec91e61718f')
package() {
cd "$pkgname-$pkgver/files"
diff --git a/tor-router.install b/tor-router.install
index e5eb8873b38c..5d1b450dadc3 100644
--- a/tor-router.install
+++ b/tor-router.install
@@ -7,11 +7,11 @@ post_install() {
torconfigbackup="/etc/tor/torrc.backup"
if grep -iq "# Seting up TOR transparent proxy for tor-router" "$torconfig" ; then
- echo -e "BlackArch ==> tor-router is already configured in $torconfig"
+ echo -e "tor-router is already configured in $torconfig"
else
- echo -e "BlackArch ==> Making a backup of your torrc file, if you have problems with the new configuration, delete $torconfig and move $torconfigbackup to $torconfig"
+ echo -e "Making a backup of your torrc file, if you have problems with the new configuration, delete $torconfig and move $torconfigbackup to $torconfig"
cp "$torconfig" "$torconfigbackup"
- echo -e "BlackArch ==> Configuring the torrc file to use TOR as a transparent proxy..."
+ echo -e "Configuring the torrc file to use TOR as a transparent proxy..."
echo -e "\n# Seting up TOR transparent proxy for tor-router\nVirtualAddrNetwork 10.192.0.0/10\nAutomapHostsOnResolve 1\nTransPort 9040\nDNSPort 5353" >> "$torconfig"
fi
}
@@ -19,3 +19,4 @@ post_install() {
post_upgrade() {
post_install
}
+