summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-02-24 16:32:07 -0700
committerMark Wagie2020-02-24 16:32:07 -0700
commitfa75bd2fed8861f568a70fc00c58b6190ebf7e3e (patch)
treecb2b4d080888a556f523869cbf861b45f5ddc41e
parent7e1e735fb7354b3b897961a7bdcdf94ad43af33a (diff)
downloadaur-fa75bd2fed8861f568a70fc00c58b6190ebf7e3e.tar.gz
PKGBUILD tweaks
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2e465646e508..7af105258cc9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,5 @@
-# Generated by mksrcinfo v8
-# Tue Jan 14 06:02:36 UTC 2020
pkgbase = torbrowser-launcher-git
- pkgdesc = Securely and easily download, verify, install, and launch Tor Browser
+ pkgdesc = Securely and easily download, verify, install and launch Tor Browser
pkgver = 0.3.2.r24.fc2073d
pkgrel = 1
url = https://github.com/micahflee/torbrowser-launcher
diff --git a/PKGBUILD b/PKGBUILD
index 5f472bd9c09d..ee4db81e683d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,11 +3,12 @@
pkgname=torbrowser-launcher-git
pkgver=0.3.2.r24.fc2073d
pkgrel=1
-pkgdesc="Securely and easily download, verify, install, and launch Tor Browser"
+pkgdesc="Securely and easily download, verify, install and launch Tor Browser"
arch=('any')
url="https://github.com/micahflee/torbrowser-launcher"
license=('MIT')
-depends=('tor' 'gnupg' 'pygtk' 'python-gnupg' 'python-gpgme' 'python-pyqt5' 'python-twisted' 'python-distro')
+depends=('tor' 'gnupg' 'pygtk' 'python-gnupg' 'python-gpgme' 'python-pyqt5' 'python-twisted'
+ 'python-distro')
makedepends=('git' 'python-setuptools')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -17,8 +18,8 @@ sha256sums=('SKIP'
'492ef44a6246e2e3d26feeeb317aa629fda9c0c229d0a64a8174f71492ead900')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
- printf "%s" "$(git describe --long | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g')"
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long | sed 's/^v//;s/\([^-]*-\)g/r\1/;s/-/./g'
}
prepare() {
@@ -32,7 +33,8 @@ build() {
}
package() {
- cd "$srcdir/${pkgname%-git}"
- python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
- install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/${pkgname%-git}"
+ cd "$srcdir/${pkgname%-git}"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/${pkgname%-git}"
}