summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2018-07-08 12:33:19 +0800
committerJingbei Li2018-07-08 12:33:19 +0800
commitb29eb8155633c748cc43a3ae04511fa5b613612f (patch)
tree5b061f18c0a4ddc2f0f152e5722fc583ee6b8a9e
parentfc49b1939f7bf95e2b5751679315ae3c1ae1fb0b (diff)
downloadaur-b29eb8155633c748cc43a3ae04511fa5b613612f.tar.gz
updated gcc version
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b6f40ea0535..4974101b1025 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Wed Oct 11 18:44:53 UTC 2017
pkgbase = torch7-warp-ctc
pkgdesc = A fast parallel implementation of CTC, on both CPU and GPU.
- pkgver = v1.0.r28.g14858fe
+ pkgver = v1.0.r30.g6d5b8fa
pkgrel = 1
url = https://github.com/baidu-research/warp-ctc
arch = x86_64
@@ -12,7 +10,7 @@ pkgbase = torch7-warp-ctc
makedepends = git
makedepends = torch7-cutorch-git
depends = torch7-git>=r819
- optdepends = torch7-cutorch-git: For GPU support
+ optdepends = torch7-cutorch-git
source = torch7-warp-ctc::git+https://github.com/baidu-research/warp-ctc
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 7308c44ffecb..5bd760704582 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Jingbei Li <i@jingbei.lli>
pkgdesc='A fast parallel implementation of CTC, on both CPU and GPU.'
pkgname='torch7-warp-ctc'
-pkgver=v1.0.r28.g14858fe
+pkgver=v1.0.r30.g6d5b8fa
pkgrel=1
makedepends=('cmake' 'git' 'torch7-cutorch-git')
depends=('torch7-git>=r819')
-optdepends=('torch7-cutorch-git: For GPU support')
+optdepends=('torch7-cutorch-git')
arch=('x86_64' 'i686')
url='https://github.com/baidu-research/warp-ctc'
license=('APACHE')
@@ -29,7 +29,10 @@ build () {
sed 's/luajit/luajit-5.1/g' -i CMakeLists.txt
# Uncomment this line if you are using a Pascal GPU
# sed -e 's/compute_[0-9]\{2\}/compute_61/g' -e 's/sm_[0-9]\{2\}/sm_61/g' -i CMakeLists.txt
- cmake . -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_C_COMPILER=gcc-5 -DCMAKE_BUILD_TYPE=Release
+ cmake . \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_C_COMPILER=gcc-7 \
+ -DCMAKE_BUILD_TYPE=Release
make
}