summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn-Michael Mulesa2021-08-31 12:48:50 +1000
committerJohn-Michael Mulesa2021-08-31 12:48:50 +1000
commit43505ae88d951c794f5bb20b1d7d96dea4b068a1 (patch)
treede4e10fd34d810b61df6fd826906ffbdb20df523
downloadaur-43505ae88d951c794f5bb20b1d7d96dea4b068a1.tar.gz
Initial commit.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD38
-rw-r--r--torchlight2-gog3
-rw-r--r--torchlight2-gog.desktop8
4 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab984ba9b89f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = torchlight2-gog
+ pkgdesc = GOG version of Torchlight 2
+ pkgver = 1.25.9.7
+ pkgrel = 1
+ url = http://www.gog.com/game/torchlight_ii
+ arch = i686
+ arch = x86_64
+ groups = games
+ license = custom
+ depends = libgl
+ depends = libx11
+ depends = libxext
+ depends = desktop-file-utils
+ source = gog_torchlight_2_2.0.0.2.sh::gogdownloader://torchlight_ii/en3installer2
+ source = torchlight2-gog
+ source = torchlight2-gog.desktop
+ sha256sums = ae50c7f6d423f59242cb7d6bf0b525880e94061a554fc3c37561db7a5568c998
+ sha256sums = a0df2d18749b3cc37d6fc659f84c1e5bbabe16f1698f0d4ee9a557284fc9e37e
+ sha256sums = 00bb69d20618fd9ba0466b49d0c3e6208a65e745acf8ae8e0f66efad7adb65a6
+
+pkgname = torchlight2-gog
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0e3865379d2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: John-Michael Mulesa <jmulesa at gmail dot com>
+
+pkgname=torchlight2-gog
+pkgver=1.25.9.7
+pkgrel=1
+pkgdesc="GOG version of Torchlight 2"
+arch=("i686" "x86_64")
+url="http://www.gog.com/game/torchlight_ii"
+license=("custom")
+groups=("games")
+source=("gog_torchlight_2_2.0.0.2.sh::gogdownloader://torchlight_ii/en3installer2" "torchlight2-gog" "torchlight2-gog.desktop")
+sha256sums=('ae50c7f6d423f59242cb7d6bf0b525880e94061a554fc3c37561db7a5568c998'
+ 'a0df2d18749b3cc37d6fc659f84c1e5bbabe16f1698f0d4ee9a557284fc9e37e'
+ '00bb69d20618fd9ba0466b49d0c3e6208a65e745acf8ae8e0f66efad7adb65a6')
+depends=(libgl libx11 libxext desktop-file-utils)
+
+package() {
+ # game files
+ mkdir -p "${pkgdir}/opt/${pkgname}"
+ cp -r "${srcdir}/data/noarch/"* "${pkgdir}/opt/${pkgname}/"
+
+ # launcher
+ chmod 755 "${pkgdir}/opt/${pkgname}/start.sh"
+ install -Dm755 "${srcdir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+
+ # desktop environment integration
+ install -Dm644 \
+ "${srcdir}/data/noarch/support/icon.png" \
+ "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ install -Dm644 \
+ "${srcdir}/${pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ # license
+ install -Dm644 \
+ "${srcdir}/data/noarch/docs/End User License Agreement.txt" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
diff --git a/torchlight2-gog b/torchlight2-gog
new file mode 100644
index 000000000000..b6e0b9bc85b2
--- /dev/null
+++ b/torchlight2-gog
@@ -0,0 +1,3 @@
+#!/bin/bash
+cd /opt/torchlight2-gog
+./start.sh
diff --git a/torchlight2-gog.desktop b/torchlight2-gog.desktop
new file mode 100644
index 000000000000..7485a21ce220
--- /dev/null
+++ b/torchlight2-gog.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Torchlight 2
+Comment=GOG version of Torchlight 2
+Exec=/usr/bin/torchlight2-gog
+Icon=torchlight2-gog
+Terminal=false
+Type=Application
+Categories=Game;