summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn-Michael Mulesa2021-09-22 17:11:06 +1000
committerJohn-Michael Mulesa2021-09-22 17:11:06 +1000
commite9113cb7d3ae9655f18214fde308404f0c0c1ab4 (patch)
tree1e5bd80575cca610a2501a5b05a93f4e725585e7
parent7b4d0846061f3ccde3eebb1c6fdd79cac20420da (diff)
downloadaur-e9113cb7d3ae9655f18214fde308404f0c0c1ab4.tar.gz
Fixes/structure changes.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD32
-rw-r--r--torchlight2-gog3
-rw-r--r--torchlight2-gog.desktop8
-rw-r--r--torchlight2.desktop8
-rw-r--r--torchlight2.sh3
6 files changed, 35 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ab984ba9b89f..d051ad4d9562 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = torchlight2-gog
- pkgdesc = GOG version of Torchlight 2
+ pkgdesc = Torchlight 2 Linux-native with data via GOG
pkgver = 1.25.9.7
- pkgrel = 1
+ pkgrel = 2
url = http://www.gog.com/game/torchlight_ii
arch = i686
arch = x86_64
@@ -11,11 +11,12 @@ pkgbase = torchlight2-gog
depends = libx11
depends = libxext
depends = desktop-file-utils
+ provides = torchlight2
source = gog_torchlight_2_2.0.0.2.sh::gogdownloader://torchlight_ii/en3installer2
- source = torchlight2-gog
- source = torchlight2-gog.desktop
+ source = torchlight2.sh
+ source = torchlight2.desktop
sha256sums = ae50c7f6d423f59242cb7d6bf0b525880e94061a554fc3c37561db7a5568c998
- sha256sums = a0df2d18749b3cc37d6fc659f84c1e5bbabe16f1698f0d4ee9a557284fc9e37e
- sha256sums = 00bb69d20618fd9ba0466b49d0c3e6208a65e745acf8ae8e0f66efad7adb65a6
+ sha256sums = 3b53b2adc6d1e1147fb48c2c997a360c2e2969e80195ef56f6036de22a28246e
+ sha256sums = b6bb77692d6d7319d57e3ac22bc4989cdc1ae0512f762f7d3c9f5b75335c250d
pkgname = torchlight2-gog
diff --git a/PKGBUILD b/PKGBUILD
index 901bc46dda7c..38d589683562 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,44 @@
# Maintainer: John-Michael Mulesa <jmulesa at gmail dot com>
pkgname=torchlight2-gog
+_pkgname=torchlight2
pkgver=1.25.9.7
-pkgrel=1
-pkgdesc="GOG version of Torchlight 2"
+pkgrel=2
+pkgdesc="Torchlight 2 Linux-native with data via GOG"
arch=("i686" "x86_64")
url="http://www.gog.com/game/torchlight_ii"
license=("custom")
groups=("games")
-source=("gog_torchlight_2_2.0.0.2.sh::gogdownloader://torchlight_ii/en3installer2" "torchlight2-gog" "torchlight2-gog.desktop")
-sha256sums=('ae50c7f6d423f59242cb7d6bf0b525880e94061a554fc3c37561db7a5568c998'
- 'a0df2d18749b3cc37d6fc659f84c1e5bbabe16f1698f0d4ee9a557284fc9e37e'
- '00bb69d20618fd9ba0466b49d0c3e6208a65e745acf8ae8e0f66efad7adb65a6')
+provides=('torchlight2')
+source=("gog_torchlight_2_2.0.0.2.sh::gogdownloader://torchlight_ii/en3installer2" "${_pkgname}.sh" "${_pkgname}.desktop")
depends=(libgl libx11 libxext desktop-file-utils)
+sha256sums=('ae50c7f6d423f59242cb7d6bf0b525880e94061a554fc3c37561db7a5568c998'
+ '3b53b2adc6d1e1147fb48c2c997a360c2e2969e80195ef56f6036de22a28246e'
+ 'b6bb77692d6d7319d57e3ac22bc4989cdc1ae0512f762f7d3c9f5b75335c250d')
# If you want to use lgogdownloader add the following to /etc/makepkg.conf
-# DLAGENTS+=('goggogdownloader::/usr/bin/lgogdownloader --download-file=%u -o %o')
+# DLAGENTS+=('gogdownloader::/usr/bin/lgogdownloader --download-file=%u -o %o')
DLAGENTS+=("gogdownloader::/usr/bin/echo Could not find gog installer file (%u). Manually download it to \"$(pwd)\", or set up a gogdownloader:// DLAGENT in /etc/makepkg.conf. See PKGBUILD for example.")
package() {
# game files
- mkdir -p "${pkgdir}/opt/${pkgname}"
- cp -r "${srcdir}/data/noarch/"* "${pkgdir}/opt/${pkgname}/"
+ mkdir -p "${pkgdir}/opt/${_pkgname}"
+ cp -r "${srcdir}/data/noarch/"* "${pkgdir}/opt/${_pkgname}/"
# launcher
- chmod 755 "${pkgdir}/opt/${pkgname}/start.sh"
- install -Dm755 "${srcdir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ chmod 755 "${pkgdir}/opt/${_pkgname}/start.sh"
+ install -Dm755 "${srcdir}/${_pkgname}.sh" "${pkgdir}/usr/bin/${_pkgname}"
# desktop environment integration
install -Dm644 \
"${srcdir}/data/noarch/support/icon.png" \
- "${pkgdir}/usr/share/pixmaps/${pkgname}.png"
+ "${pkgdir}/usr/share/pixmaps/${_pkgname}.png"
install -Dm644 \
- "${srcdir}/${pkgname}.desktop" \
- "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ "${srcdir}/${_pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
# license
install -Dm644 \
"${srcdir}/data/noarch/docs/End User License Agreement.txt" \
- "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
}
diff --git a/torchlight2-gog b/torchlight2-gog
deleted file mode 100644
index b6e0b9bc85b2..000000000000
--- a/torchlight2-gog
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/bash
-cd /opt/torchlight2-gog
-./start.sh
diff --git a/torchlight2-gog.desktop b/torchlight2-gog.desktop
deleted file mode 100644
index 7485a21ce220..000000000000
--- a/torchlight2-gog.desktop
+++ /dev/null
@@ -1,8 +0,0 @@
-[Desktop Entry]
-Name=Torchlight 2
-Comment=GOG version of Torchlight 2
-Exec=/usr/bin/torchlight2-gog
-Icon=torchlight2-gog
-Terminal=false
-Type=Application
-Categories=Game;
diff --git a/torchlight2.desktop b/torchlight2.desktop
new file mode 100644
index 000000000000..d13b60c867ba
--- /dev/null
+++ b/torchlight2.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Torchlight 2
+Comment=Torchlight II Linux-native
+Exec=/usr/bin/torchlight2
+Icon=torchlight2
+Terminal=false
+Type=Application
+Categories=Game;
diff --git a/torchlight2.sh b/torchlight2.sh
new file mode 100644
index 000000000000..c4b9f7222e59
--- /dev/null
+++ b/torchlight2.sh
@@ -0,0 +1,3 @@
+#!/bin/bash
+cd /opt/torchlight2
+./start.sh