summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordramm2018-08-28 15:38:32 -0300
committerdramm2018-08-28 15:38:32 -0300
commit261519898136286663f34768ab7e7b42dbb37f05 (patch)
treeff243015ece9f1d3f40353048557a305126fe555
parentb947b8eac38c9782ff5994251ec3b73bfaa413c4 (diff)
downloadaur-261519898136286663f34768ab7e7b42dbb37f05.tar.gz
updated to v.3.88.0
-rw-r--r--.INSTALL12
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
3 files changed, 27 insertions, 9 deletions
diff --git a/.INSTALL b/.INSTALL
new file mode 100644
index 000000000000..2ec4029c97e6
--- /dev/null
+++ b/.INSTALL
@@ -0,0 +1,12 @@
+pre_install() {
+ if ! grep -q "^torguard:" /etc/group ; then groupadd --system torguard; fi
+}
+
+pre_upgrade() {
+ if ! grep -q "^torguard:" /etc/group ; then groupadd --system torguard; fi
+}
+
+post_remove() {
+ if grep -q "^torguard:" /etc/group ; then groupdel torguard; fi
+}
+
diff --git a/.SRCINFO b/.SRCINFO
index 386f2ebd3af3..d8e29a1ee3f4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = torguard
pkgdesc = TorGuard VPN Software Stay private online with TorGuard's anonymous VPN software and connect to 37+ countries worldwide.
- pkgver = 3.85.0
+ pkgver = 3.88.0
pkgrel = 1
url = www.torguard.com
+ install = .INSTALL
arch = x86_64
license = custom
depends = iproute2
- source = https://updates.torguard.biz/Software/Linux/torguard-v3.85.0-amd64-arch.tar.gz
- md5sums = 55c7a9dfb9b40490999f75ea9c445246
+ source = https://updates.torguard.biz/Software/Linux/torguard-v3.88.0-amd64-arch.tar.gz
+ md5sums = a2e83a90333de540f426cf59577b4eed
pkgname = torguard
diff --git a/PKGBUILD b/PKGBUILD
index b915302715db..2d5252a8683a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,9 @@
# Maintainer: coco
-# Co-Maintainer: thatgeek
+# Co-Maintainer: dramm
+# Contributor: thatgeek
+# Contributor: TorGuard Support <support@torguard.com>
pkgname=torguard
-pkgver=3.85.0
+pkgver=3.88.0
pkgrel=1
pkgdesc="TorGuard VPN Software
Stay private online with TorGuard's anonymous VPN software and connect to 37+ countries worldwide."
@@ -9,23 +11,26 @@ arch=('x86_64')
url="www.torguard.com"
depends=('iproute2')
license=(custom)
-source=("https://updates.torguard.biz/Software/Linux/torguard-v3.85.0-amd64-arch.tar.gz")
-md5sums=('55c7a9dfb9b40490999f75ea9c445246')
+source=("https://updates.torguard.biz/Software/Linux/torguard-v3.88.0-amd64-arch.tar.gz")
+md5sums=('a2e83a90333de540f426cf59577b4eed')
+install=.INSTALL
package() {
tar -xf "${srcdir}/${pkgname}-v${pkgver}-amd64-arch/torguard-v${pkgver}-amd64-arch.tar"
cp -r "${srcdir}/${pkgname}-v${pkgver}-amd64-arch/opt" "${pkgdir}/" -R
cp -r "${srcdir}/${pkgname}-v${pkgver}-amd64-arch/usr" "${pkgdir}/" -R
+ cp -r "$srcdir"/*/* "$pkgdir"
find "$pkgdir"/opt/torguard/ -type f -exec chmod 644 {} \;
find "$pkgdir"/opt/torguard/ -name torguard -exec chmod 755 {} \;
find "$pkgdir"/opt/torguard/ -name torguard-wrapper -exec chmod 755 {} \;
find "$pkgdir"/opt/torguard/ -name ss-local -exec chmod 755 {} \;
- find "$pkgdir"/opt/torguard/ -name openvpn_v2_3 -exec chmod 755 {} \;
find "$pkgdir"/opt/torguard/ -name openvpn_v2_4 -exec chmod 755 {} \;
find "$pkgdir"/opt/torguard/ -name openconnect -exec chmod 755 {} \;
find "$pkgdir"/opt/torguard/ -name vpnc-script -exec chmod 755 {} \;
find "$pkgdir"/opt/torguard/ -name stunnel -exec chmod 755 {} \;
-
+ find "$pkgdir"/opt/torguard/bin/ -name torguard-startup.desktop -exec chmod 664 {} \;
+ find "$pkgdir"/etc/sudoers.d/ -name torguard -exec chmod 440 {} \;
+ find "$pkgdir"/etc/sudoers.d/ -type d -exec chmod 750 {} \;
install -d "$pkgdir"/usr/bin/
ln -s /opt/torguard/bin/torguard-wrapper "$pkgdir"/usr/bin/torguard