summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcoco2017-01-25 15:54:50 +0000
committercoco2017-01-25 16:17:55 +0000
commit5c23d5647de1d504fb9a7e02a6d6e74460d801e2 (patch)
tree5841b12af85c3bf72cdae4cd022128f22a583195
downloadaur-5c23d5647de1d504fb9a7e02a6d6e74460d801e2.tar.gz
x64 repackaging
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..36d4f4d04b94
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = torguard
+ pkgdesc = TorGuard VPN Software Stay private online with TorGuard's anonymous VPN software and connect to 37+ countries worldwide.
+ pkgver = 0.3.59
+ pkgrel = 1
+ url = www.torguard.com
+ arch = x86_64
+ license = custom
+ depends = iproute2
+ source = code_x64_0.3.59.tar.gz::http://updates.torguard.biz/Software/Linux/torguard-v0.3.59-amd64.tar.gz
+ md5sums = afd93670483381dbd5b565823022147c
+
+pkgname = torguard
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..edb02a56f572
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname=torguard
+pkgver=0.3.59
+pkgrel=1
+pkgdesc="TorGuard VPN Software
+ Stay private online with TorGuard's anonymous VPN software and connect to 37+ countries worldwide."
+arch=('x86_64')
+url="www.torguard.com"
+depends=('iproute2')
+license=(custom)
+source=(code_x64_${pkgver}.tar.gz::http://updates.torguard.biz/Software/Linux/torguard-v0.3.59-amd64.tar.gz)
+md5sums=('afd93670483381dbd5b565823022147c')
+
+package() {
+
+ mkdir -p "$pkgdir/opt/${pkgname}"
+ cp -r "${srcdir}/${pkgname}-v0.3.59-amd64/"* "${pkgdir}/opt/${pkgname}" -R
+ find "$pkgdir" -type f -exec chmod 644 {} \;
+ find "$pkgdir" -name torguard -exec chmod 755 {} \;
+ find "$pkgdir" -name torguard-wrapper -exec chmod 755 {} \;
+ find "$pkgdir" -name ss-local -exec chmod 755 {} \;
+ find "$pkgdir" -name openvpn -exec chmod 755 {} \;
+
+ install -d "$pkgdir"/usr/bin/
+ ln -s /opt/torguard/bin/torguard-wrapper "$pkgdir"/usr/bin/torguard
+}