summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCyker Way2015-12-19 09:16:09 +0800
committerCyker Way2015-12-19 09:16:09 +0800
commit40bf3a09c31cfb2b627da9061eafb329d4d56594 (patch)
tree15e71e937635bdd973c12a8f2cfd060da0ec871d
downloadaur-40bf3a09c31cfb2b627da9061eafb329d4d56594.tar.gz
Initial commit.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD38
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..564332503fd1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sat Dec 19 01:15:38 UTC 2015
+pkgbase = torita
+ pkgdesc = A torrent-aware package downloader.
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://github.com/cykerway/torita
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = aria2
+ depends = mktorrent
+ optdepends = curl
+ optdepends = wget
+ source = https://github.com/cykerway/torita/archive/v1.2.tar.gz
+ sha256sums = d8f2ae4771cc341181ede8aabf4fd321eb088194b299745c66bbb9224d624d56
+
+pkgname = torita
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e872bbeb59c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Cyker Way <cykerway at gmail dot com>
+
+pkgname=torita
+pkgver=1.2
+pkgrel=1
+epoch=
+pkgdesc="A torrent-aware package downloader."
+arch=('i686' 'x86_64')
+url="https://github.com/cykerway/torita"
+license=('GPL3')
+groups=()
+depends=('aria2' 'mktorrent')
+makedepends=()
+checkdepends=()
+optdepends=('curl' 'wget')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/cykerway/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('d8f2ae4771cc341181ede8aabf4fd321eb088194b299745c66bbb9224d624d56')
+noextract=()
+validpgpkeys=()
+
+build() {
+ cd "$pkgname-$pkgver"
+# ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+