summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpushsla2020-06-11 21:05:51 +0500
committerpushsla2020-06-11 21:05:51 +0500
commit03ff29db80953159e6c99f05c2700f734658b816 (patch)
treec070f243b9909e221762bf757b523a5ef3702548
parentea99e96fc292de1bd90256a9d129b9c0fcc8bcc1 (diff)
downloadaur-03ff29db80953159e6c99f05c2700f734658b816.tar.gz
git pkgver
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7c9fc888c70..00703dd5bfe0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = torodofi-git
pkgdesc = Simple ToDo task manager using pure MarkDown file to store your tasks. Active/Done, tags, deadlines support. Rofi GUI.
- pkgver = 0.9
- pkgrel = 4
+ pkgver = 89.r73e5b7d
+ pkgrel = 1
url = https://github.com/pushsla/torodofi
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index b02887428d53..d8fb58ee9753 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,9 @@
# Maintainer: pushsla <github.com/pushsla>
pkgname=torodofi-git
-pkgver=0.9
-pkgrel=4
+_pkgname=torodofi
+pkgver=89.r73e5b7d
+pkgrel=1
pkgdesc="Simple ToDo task manager using pure MarkDown file to store your tasks. Active/Done, tags, deadlines support. Rofi GUI."
arch=('x86_64')
url="https://github.com/pushsla/torodofi"
@@ -15,12 +16,12 @@ source=("git+https://github.com/pushsla/torodofi.git")
md5sums=('SKIP')
pkgver() {
- cd "$pkgname"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "${_pkgname}"
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd "$srcdir/torodofi"
+ cd "$srcdir/${_pkgname}"
cmake -DCMAKE_INSTALL_PREFIX=/usr -S . -B build
cmake --build build
}