summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavide Iosca2016-07-30 16:12:27 +0200
committerDavide Iosca2016-07-30 16:12:27 +0200
commit3682a12892f35e10e530a6379456e3d031019f4b (patch)
tree74d29fb2b73bd444aff2dfbeae691e3c10eee992
downloadaur-3682a12892f35e10e530a6379456e3d031019f4b.tar.gz
Version 0.9.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b05a17262921
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = torram
+ pkgdesc = Recreates a torrent download folder with fully and partially downloaded files
+ pkgver = 0.9.0
+ pkgrel = 1
+ url = https://github.com/vbuell/torram
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python2
+ depends = python2-bencode
+ optdepends = python2-pyqt4: For using qBittorrent output directory autodetection
+ source = git+https://github.com/vbuell/torram.git
+ sha1sums = SKIP
+
+pkgname = torram
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d60dcd80a80b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Davide Iosca <dvdios [at] aol [dot] com>
+
+pkgname='torram'
+pkgdesc='Recreates a torrent download folder with fully and partially downloaded files'
+pkgver=0.9.0
+pkgrel=1
+url='https://github.com/vbuell/torram'
+arch=('any')
+license=('GPL')
+depends=('python2' 'python2-bencode')
+optdepends=('python2-pyqt4: For using qBittorrent output directory autodetection')
+source=('git+https://github.com/vbuell/torram.git')
+sha1sums=('SKIP')
+makedepends=('git')
+
+package() {
+ cd ./torram
+ python2 setup.py install --prefix=/usr --root="${pkgdir}" || return 1
+}
+