summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosip2016-04-28 14:17:18 +0200
committerJosip2016-04-28 14:17:18 +0200
commit854ab3249e3b010d31a3b39d38c7624198ef2732 (patch)
treec596006171fe571e9391c4a117d07afcaf550ded
parent3db465cc58fc3667d243c22ed3edad5ff849e755 (diff)
downloadaur-854ab3249e3b010d31a3b39d38c7624198ef2732.tar.gz
Use hooks...
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD23
-rw-r--r--torrent-file-editor.install13
3 files changed, 12 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1f8e72dd5ab..0249fc3f1d7a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,8 @@
-# Generated by mksrcinfo v8
-# Thu Jan 7 00:24:34 UTC 2016
pkgbase = torrent-file-editor-qt5-git
pkgdesc = Qt based GUI tool designed to create and edit .torrent files. Qt5 build
pkgver = v0.2.1.r28.g8462745
- pkgrel = 1
+ pkgrel = 2
url = https://sourceforge.net/projects/torrent-file-editor/
- install = torrent-file-editor.install
arch = i686
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 5cb6c898d8f0..abb4db7805f2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=torrent-file-editor-qt5-git
_pkgname=torrent-file-editor
pkgver=v0.2.1.r28.g8462745
-pkgrel=1
+pkgrel=2
pkgdesc="Qt based GUI tool designed to create and edit .torrent files. Qt5 build"
arch=('i686' 'x86_64')
url='https://sourceforge.net/projects/torrent-file-editor/'
@@ -13,25 +13,24 @@ depends=('desktop-file-utils' 'hicolor-icon-theme' 'qt5-base')
makedepends=('cmake' 'git' 'qt5-tools')
provides=("${_pkgname}" "${_pkgname}-qt5")
conflicts=("${_pkgname}" "${_pkgname}-qt4")
-install="${_pkgname}.install"
source=("git+https://github.com/drizt/torrent-file-editor.git")
md5sums=('SKIP')
pkgver() {
- cd "${_pkgname}"
- git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+ cd "${_pkgname}"
+ git describe --long --tags | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
}
build() {
- cd "${_pkgname}"
- cmake . \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DQT5_BUILD=ON
- make
+ cd "${_pkgname}"
+ cmake . \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DQT5_BUILD=ON
+ make
}
package() {
- cd "${_pkgname}"
- make DESTDIR="${pkgdir}" install
+ cd "${_pkgname}"
+ make DESTDIR="${pkgdir}" install
}
diff --git a/torrent-file-editor.install b/torrent-file-editor.install
deleted file mode 100644
index 01c337ba1013..000000000000
--- a/torrent-file-editor.install
+++ /dev/null
@@ -1,13 +0,0 @@
-post_install() {
- update-desktop-database -q &> /dev/null
- xdg-icon-resource forceupdate --theme hicolor &> /dev/null
-}
-
-post_upgrade() {
- post_install
-}
-
-post_remove() {
- post_install
-}
-