summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexandre Bouvier2021-04-21 22:56:14 +0200
committerAlexandre Bouvier2021-04-21 22:56:14 +0200
commit43725c56abaee947c29c00346b78c1530dd4c00c (patch)
tree7ff295e97f573014ab8165f2b6252c165ab8a204
downloadaur-43725c56abaee947c29c00346b78c1530dd4c00c.tar.gz
version 1.3
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
-rw-r--r--fix-gcc-error.patch22
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52aeb53ed211
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = torrent7z
+ pkgdesc = A fork of torrent7z, viz a derivative of 7zip that produces invariant .7z archives for torrenting
+ pkgver = 1.3
+ pkgrel = 1
+ url = https://github.com/BubblesInTheTub/torrent7z
+ arch = x86_64
+ license = GPL3
+ depends = gcc-libs
+ source = torrent7z-1.3.tar.gz::https://github.com/BubblesInTheTub/torrent7z/archive/refs/tags/1.3.tar.gz
+ source = fix-gcc-error.patch
+ md5sums = 2465a59918a47d010c07794e70e06194
+ md5sums = 508ab9a64875758be785d0665a5263bd
+
+pkgname = torrent7z
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2149119b8b31
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Alexandre Bouvier <contact@amb.tf>
+# shellcheck shell=bash disable=SC2034,SC2164
+pkgname=torrent7z
+pkgver=1.3
+pkgrel=1
+pkgdesc="A fork of torrent7z, viz a derivative of 7zip that produces invariant .7z archives for torrenting"
+arch=('x86_64')
+url="https://github.com/BubblesInTheTub/torrent7z"
+license=('GPL3')
+depends=('gcc-libs')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/$pkgver.tar.gz"
+ 'fix-gcc-error.patch')
+md5sums=('2465a59918a47d010c07794e70e06194'
+ '508ab9a64875758be785d0665a5263bd')
+
+prepare() {
+ cd $pkgname-$pkgver
+ patch -p1 < ../fix-gcc-error.patch
+}
+
+build() {
+ cd $pkgname-$pkgver
+ make -C linux_src/p7zip_4.65
+}
+
+package() {
+ cd $pkgname-$pkgver
+ # shellcheck disable=SC2154
+ install -D -t "$pkgdir"/usr/bin linux_src/p7zip_4.65/bin/t7z
+}
diff --git a/fix-gcc-error.patch b/fix-gcc-error.patch
new file mode 100644
index 000000000000..64aef603282a
--- /dev/null
+++ b/fix-gcc-error.patch
@@ -0,0 +1,22 @@
+From 5958f42a364c430b3ed4ac68911bbbea1f967fc4 Mon Sep 17 00:00:00 2001
+From: paulyc <paulyc@quetzalcoatl.us>
+Date: Fri, 29 Jan 2021 08:09:01 -0500
+Subject: [PATCH] GCC 10.2 is picky about the signdedness of switch cases
+
+---
+ linux_src/p7zip_4.65/CPP/Windows/Error.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/linux_src/p7zip_4.65/CPP/Windows/Error.cpp b/linux_src/p7zip_4.65/CPP/Windows/Error.cpp
+index 88008d7..e3ad9a4 100644
+--- a/linux_src/p7zip_4.65/CPP/Windows/Error.cpp
++++ b/linux_src/p7zip_4.65/CPP/Windows/Error.cpp
+@@ -13,7 +13,7 @@ bool MyFormatMessage(DWORD messageID, CSysString &message)
+ const char * txt = 0;
+ AString msg;
+
+- switch(messageID) {
++ switch((HRESULT)messageID) {
+ case ERROR_NO_MORE_FILES : txt = "No more files"; break ;
+ case E_NOTIMPL : txt = "E_NOTIMPL"; break ;
+ case E_NOINTERFACE : txt = "E_NOINTERFACE"; break ;