aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaulo Diovani2016-06-06 00:59:07 -0300
committerPaulo Diovani2016-06-06 01:26:09 -0300
commit1db5613e1b3ef73f757afdfcfef2af762ab2b2c8 (patch)
tree2904afe89b6df072e4c5f6395f32668f131bb923
downloadaur-1db5613e1b3ef73f757afdfcfef2af762ab2b2c8.tar.gz
Add PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD23
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ac2dc22638d2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = torrentflix
+ pkgdesc = Nodejs cli app to search torrent sites and stream using peerflix
+ pkgver = 8.6.2
+ pkgrel = 1
+ url = https://www.npmjs.com/package/torrentflix
+ arch = any
+ license = MIT
+ makedepends = npm
+ depends = nodejs
+ depends = peerflix
+ options = !emptydirs
+ source = https://github.com/ItzBlitz98/torrentflix/archive/8.6.2.tar.gz
+ sha256sums = 14e97591d34b73f74f47a14e1f12d94ec59226f54fe88572b8d9edcd71392131
+
+pkgname = torrentflix
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9baf7d44b2c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Paulo Diovani <paulo@diovani.com>
+
+pkgname=torrentflix
+pkgver=8.6.2
+pkgrel=1
+pkgdesc="Nodejs cli app to search torrent sites and stream using peerflix"
+arch=('any')
+url="https://www.npmjs.com/package/torrentflix"
+license=('MIT')
+depends=('nodejs' 'peerflix')
+makedepends=('npm')
+options=(!emptydirs)
+source=("https://github.com/ItzBlitz98/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('14e97591d34b73f74f47a14e1f12d94ec59226f54fe88572b8d9edcd71392131')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ install -Dm644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ npm install --user root -g --prefix "${pkgdir}/usr/local"
+}
+
+# vim:set ts=2 sw=2 et: