summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Rubin2024-03-10 09:07:11 +0100
committerMarco Rubin2024-03-10 09:07:11 +0100
commit425f7e1b03f68b8e451ea5523d23cfada9b079ca (patch)
treef2d5a1743197998bbee330e2a61fbcc796415fcd
parent72c761d1404ffed77624be79941f0869e8475d11 (diff)
downloadaur-425f7e1b03f68b8e451ea5523d23cfada9b079ca.tar.gz
PEP 517 building
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6558d874990a..fa78bc53abd3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,15 @@
pkgbase = torrentinfo
pkgdesc = Bittorrent .torrent file parser and summariser
pkgver = 1.8.7
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/Fuuzetsu/torrentinfo
arch = any
license = GPL2
makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
+ makedepends = python-wheel
depends = python
source = git+https://github.com/Fuuzetsu/torrentinfo#commit=3c9b3ba80c867ba28e8ce0982fec8ea5369df8ef
b2sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index f65c374a2d51..ece95317772d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
pkgname=torrentinfo
pkgver=1.8.7
-pkgrel=2
+pkgrel=3
pkgdesc="Bittorrent .torrent file parser and summariser"
arch=('any')
url="https://github.com/Fuuzetsu/torrentinfo"
license=(GPL2)
depends=(python)
-makedepends=(git python-setuptools)
+makedepends=(git python-build python-installer python-setuptools python-wheel)
source=("git+$url#commit=3c9b3ba80c867ba28e8ce0982fec8ea5369df8ef")
b2sums=('SKIP')
@@ -21,10 +21,10 @@ prepare() {
build() {
cd $pkgname
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd $pkgname
- python setup.py install --root="$pkgdir/" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}