summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarco Rubin2022-12-03 11:41:09 +0100
committerMarco Rubin2022-12-03 11:41:09 +0100
commitde4c76124997f1ac5d2110bd557dfe640d7a9916 (patch)
treeaf4317ee55518591eeb707934e7ce8d77ab329a3
parent8ae6a75e759af6f19f9eb0bae6ab7870e74f1418 (diff)
downloadaur-de4c76124997f1ac5d2110bd557dfe640d7a9916.tar.gz
1.8.7
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD28
2 files changed, 24 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8be17ad2fa7a..b509ade31ef9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = torrentinfo
pkgdesc = Bittorrent .torrent file parser and summariser
- pkgver = 1.8.6
+ pkgver = 1.8.7
pkgrel = 1
url = https://github.com/Fuuzetsu/torrentinfo
arch = any
license = GPL2
- depends = python2
- source = https://github.com/Fuuzetsu/torrentinfo/archive/v1.8.6.tar.gz
- sha1sums = b3e17039b081e383dda92dae5c614698cba2398d
+ makedepends = python-setuptools
+ depends = python
+ source = git+https://github.com/Fuuzetsu/torrentinfo#commit=3c9b3ba80c867ba28e8ce0982fec8ea5369df8ef
+ b2sums = SKIP
pkgname = torrentinfo
-
diff --git a/PKGBUILD b/PKGBUILD
index dc967394191c..2e689ec566b1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,30 @@
-# Maintainer: Florian Bruhin <archlinux.org@the-compiler.org>
+# Maintainer: Marco Rubin <marco.rubin@protonmail.com>
+# Contributor: Florian Bruhin <archlinux.org@the-compiler.org>
# Contributor: Roman G <drakosha@au.ru>
pkgname=torrentinfo
-pkgver=1.8.6
+pkgver=1.8.7
pkgrel=1
pkgdesc="Bittorrent .torrent file parser and summariser"
arch=('any')
url="https://github.com/Fuuzetsu/torrentinfo"
license=('GPL2')
-depends=('python2')
-source=("https://github.com/Fuuzetsu/torrentinfo/archive/v${pkgver}.tar.gz")
-sha1sums=('b3e17039b081e383dda92dae5c614698cba2398d')
+depends=('python')
+makedepends=('python-setuptools')
+source=("git+$url#commit=3c9b3ba80c867ba28e8ce0982fec8ea5369df8ef")
+b2sums=('SKIP')
-package() {
- cd "$srcdir/$pkgname-$pkgver"
- python2 setup.py install --root="$pkgdir/" --optimize=1
+prepare() {
+ cd $pkgname
+ sed -i "s/os.name is/os.name ==/g" setup.py # fix warning
+}
+
+build() {
+ cd $pkgname
+ python setup.py build
}
-# vim:set ts=2 sw=2 et:
+package() {
+ cd $pkgname
+ python setup.py install --root="$pkgdir/" --optimize=1
+}