summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Majewski2020-03-10 14:02:42 +0100
committerKevin Majewski2020-03-10 14:02:42 +0100
commit5b077c5f8601649420d6834ae2092c220d51782b (patch)
treead814731dbad767c3298adf5ddd45017ebc69e05
downloadaur-5b077c5f8601649420d6834ae2092c220d51782b.tar.gz
Initial commit
-rw-r--r--.SRCINFO48
-rw-r--r--PKGBUILD47
2 files changed, 95 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef67bf87b685
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,48 @@
+pkgbase = totem-git
+ pkgdesc = Movie player for the GNOME desktop based on GStreamer
+ pkgver = 3.34.0+105+g020c9dfd6
+ pkgrel = 1
+ url = https://wiki.gnome.org/Apps/Videos
+ arch = x86_64
+ license = GPL2
+ license = custom
+ makedepends = libnautilus-extension
+ makedepends = itstool
+ makedepends = docbook-xsl
+ makedepends = python-pylint
+ makedepends = gobject-introspection
+ makedepends = git
+ makedepends = appstream-glib
+ makedepends = gtk-doc
+ makedepends = meson
+ makedepends = intltool
+ depends = totem-plparser
+ depends = iso-codes
+ depends = libpeas
+ depends = clutter-gtk
+ depends = clutter-gst
+ depends = grilo
+ depends = gsettings-desktop-schemas
+ depends = dconf
+ depends = python-gobject
+ depends = python-xdg
+ depends = gnome-desktop
+ depends = gst-plugins-base
+ depends = gst-plugins-good
+ depends = gst-plugins-bad
+ optdepends = gst-plugins-ugly: Extra media codecs
+ optdepends = gst-libav: Extra media codecs
+ optdepends = grilo-plugins: Media discovery
+ optdepends = python-dbus: MPRIS plugin
+ provides = totem
+ conflicts = totem
+ conflicts = totem-plugin
+ replaces = totem
+ replaces = totem-plugin
+ source = git+https://gitlab.gnome.org/GNOME/totem.git
+ source = git+https://gitlab.gnome.org/GNOME/libgd.git
+ sha512sums = SKIP
+ sha512sums = SKIP
+
+pkgname = totem-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9726b44f0846
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+pkgname=totem-git
+_pkgname=totem
+pkgver=3.34.0+105+g020c9dfd6
+pkgrel=1
+pkgdesc="Movie player for the GNOME desktop based on GStreamer"
+url="https://wiki.gnome.org/Apps/Videos"
+arch=(x86_64)
+license=(GPL2 custom)
+depends=('totem-plparser' 'iso-codes' 'libpeas' 'clutter-gtk' 'clutter-gst' 'grilo' 'gsettings-desktop-schemas'
+ 'dconf' 'python-gobject' 'python-xdg' 'gnome-desktop' 'gst-plugins-base' 'gst-plugins-good'
+ 'gst-plugins-bad')
+makedepends=('libnautilus-extension' 'itstool' 'docbook-xsl' 'python-pylint'
+ 'gobject-introspection' 'git' 'appstream-glib' 'gtk-doc' 'meson' 'intltool')
+optdepends=('gst-plugins-ugly: Extra media codecs'
+ 'gst-libav: Extra media codecs'
+ 'grilo-plugins: Media discovery'
+ 'python-dbus: MPRIS plugin')
+provides=('totem')
+conflicts=('totem' 'totem-plugin')
+replaces=('totem' 'totem-plugin')
+source=("git+https://gitlab.gnome.org/GNOME/totem.git"
+ "git+https://gitlab.gnome.org/GNOME/libgd.git")
+sha512sums=('SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/^V_//;s/_/./g;s/-/+/g'
+}
+
+prepare() {
+ cd $_pkgname
+
+ git submodule init
+ git config --local submodule.subprojects/libgd.url "$srcdir/libgd"
+ git submodule update
+}
+
+build() {
+ arch-meson $_pkgname build -D enable-gtk-doc=true
+ ninja -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+ install -Dt "$pkgdir/usr/share/licenses/$_pkgname" -m644 $_pkgname/COPYING
+}