summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIliyan Ivanov2024-08-11 15:19:11 +0300
committerIliyan Ivanov2024-08-11 15:19:11 +0300
commitca94e98206c2328f19e279aa1d534c910582500e (patch)
treeee967764dfbabd57508ed921a33fa0ef38db7266
downloadaur-ca94e98206c2328f19e279aa1d534c910582500e.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD16
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f5d58c75ebc8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = totp-cli-rofi
+ pkgdesc = Simple CLI TOTP tool with rofi integration
+ pkgver = 1.0.0
+ pkgrel = 1
+ arch = any
+ license = MIT
+ depends = fzf
+ depends = rofi
+ depends = jq
+ depends = gnupg
+ depends = oath-toolkit
+ depends = xdotool
+ depends = bash
+ source = totp-cli-rofi-1.0.0.tar.gz::https://github.com/eldiaboloz/totp-cli-rofi/archive/v1.0.0.tar.gz
+ sha256sums = 0178ece448f3360b62d858b5c60757cd412e6fa79789567f0d90a250383c7be7
+
+pkgname = totp-cli-rofi
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..93ee3e574151
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+/totp-cli-rofi-*
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7ef52ca68a4e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+# Maintainer: eldiaboloz <iliyan87.ivanov@gmail.com>
+pkgname=totp-cli-rofi
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Simple CLI TOTP tool with rofi integration"
+arch=('any')
+depends=('fzf' 'rofi' 'jq' 'gnupg' 'oath-toolkit' 'xdotool' 'bash')
+license=('MIT')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/eldiaboloz/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('0178ece448f3360b62d858b5c60757cd412e6fa79789567f0d90a250383c7be7')
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -m 755 -D $pkgname "$pkgdir/usr/bin/$pkgname"
+ install -m 444 -D LICENCE "$pkgdir/usr/share/doc/LICENCE"
+}