summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorYTG1232021-08-08 11:11:33 +0300
committerYTG1232021-08-08 11:11:33 +0300
commit2d173f8da8377decd89ee2a6aa324173ef2fa459 (patch)
tree695b896244e57e68aab2c225c832caef8f340a4b
downloadaur-2d173f8da8377decd89ee2a6aa324173ef2fa459.tar.gz
Initial package commit.
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD29
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf4670d6d01c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = touchcursor-linux-git
+ pkgdesc = TouchCursor style keyboard remapping for Linux, Git version.
+ pkgver = r96.1383893
+ pkgrel = 1
+ url = https://github.com/donniebreve/touchcursor-linux
+ arch = any
+ license = GPL2
+ depends = glibc
+ source = git+https://github.com/donniebreve/touchcursor-linux
+ md5sums = SKIP
+
+pkgname = touchcursor-linux-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c01009db579a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+
+!PKGBUILD
+!.SRCINFO
+!.gitignore \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2d40009f5f8f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: YTG123 <ytg1234@pm.me>
+_pkgname=touchcursor-linux
+pkgname=touchcursor-linux-git
+pkgver=r96.1383893
+pkgrel=1
+pkgdesc="TouchCursor style keyboard remapping for Linux, Git version."
+arch=("any")
+url=https://github.com/donniebreve/touchcursor-linux
+license=('GPL2')
+depends=('glibc')
+source=("git+https://github.com/donniebreve/$_pkgname")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$_pkgname"
+ make OUTPATH="./out" TARGET="touchcursor"
+}
+
+package() {
+ cd "$_pkgname"
+ install -Dm4755 out/touchcursor "$pkgdir/usr/bin/touchcursor"
+ install -Dm644 touchcursor.conf "$pkgdir/etc/touchcursor/touchcursor.conf"
+ install -Dm644 touchcursor.service "$pkgdir/usr/lib/systemd/user/touchcursor.service"
+}