summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-10-15 10:03:32 -0600
committerMark Wagie2021-10-15 10:03:32 -0600
commit1094cdb7336fe3a82558729ffebe9b4389535f20 (patch)
tree1848a97477a6d80e5eee0bcb053f3c658940ccd0
parent3db6304619673cb915dcf521769e03ade8be9ce5 (diff)
downloadaur-1094cdb7336fe3a82558729ffebe9b4389535f20.tar.gz
2.0.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5f937915457..f3f64fd63ea0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = touche
pkgdesc = The desktop application to configure Touchégg
- pkgver = 1.0.7
+ pkgver = 2.0.0
pkgrel = 1
url = https://github.com/JoseExposito/touche
arch = x86_64
@@ -10,10 +10,11 @@ pkgbase = touche
makedepends = meson
makedepends = npm
depends = gjs
- depends = gtk3
+ depends = gtk4
+ depends = libadwaita
depends = touchegg
provides = libtouche.so
- source = touche-1.0.7.tar.gz::https://github.com/JoseExposito/touche/archive/1.0.7.tar.gz
- sha256sums = d711512971f1a832e316ecf10515ca1845ee2597be9538419f8c7e79cc87b7b2
+ source = touche-2.0.0.tar.gz::https://github.com/JoseExposito/touche/archive/2.0.0.tar.gz
+ sha256sums = cff063028d074a7186cde8cf80982736e0d6eff3103e99d10f9dae7ad1379dd2
pkgname = touche
diff --git a/PKGBUILD b/PKGBUILD
index 12e09fd800fd..eeec6ff6a09a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=touche
-pkgver=1.0.7
+pkgver=2.0.0
pkgrel=1
pkgdesc="The desktop application to configure Touchégg "
arch=('x86_64')
url="https://github.com/JoseExposito/touche"
license=('GPL3')
-depends=('gjs' 'gtk3' 'touchegg')
+depends=('gjs' 'gtk4' 'libadwaita' 'touchegg')
makedepends=('gobject-introspection' 'meson' 'npm')
checkdepends=('appstream-glib')
provides=('libtouche.so')
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('d711512971f1a832e316ecf10515ca1845ee2597be9538419f8c7e79cc87b7b2')
+sha256sums=('cff063028d074a7186cde8cf80982736e0d6eff3103e99d10f9dae7ad1379dd2')
build() {
export npm_config_cache="$srcdir/npm_cache"
@@ -35,7 +35,7 @@ check() {
package() {
cd "$pkgname-$pkgver"
- DESTDIR="$pkgdir" meson install -C build
+ meson install -C build --destdir "$pkgdir"
ln -s "/usr/bin/com.github.joseexposito.$pkgname" "$pkgdir/usr/bin/$pkgname"
}