summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-09-08 08:40:33 -0600
committerMark Wagie2021-09-08 08:40:33 -0600
commit3db6304619673cb915dcf521769e03ade8be9ce5 (patch)
tree933884e90dbbc8b8438932be299a374439d426d9
parentc38b71c7cabe2eb9ad9641c822ad84e153800255 (diff)
downloadaur-3db6304619673cb915dcf521769e03ade8be9ce5.tar.gz
1.0.7
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD34
2 files changed, 21 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 30c25b1d4c7b..a5f937915457 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = touche
pkgdesc = The desktop application to configure Touchégg
- pkgver = 1.0.6
- pkgrel = 5
+ pkgver = 1.0.7
+ pkgrel = 1
url = https://github.com/JoseExposito/touche
arch = x86_64
license = GPL3
@@ -13,7 +13,7 @@ pkgbase = touche
depends = gtk3
depends = touchegg
provides = libtouche.so
- source = touche-1.0.6.tar.gz::https://github.com/JoseExposito/touche/archive/1.0.6.tar.gz
- sha256sums = 116ecdd03070c55444f3d90263d7504a132c70ba4730a6d2fd6fd936c16b9fed
+ source = touche-1.0.7.tar.gz::https://github.com/JoseExposito/touche/archive/1.0.7.tar.gz
+ sha256sums = d711512971f1a832e316ecf10515ca1845ee2597be9538419f8c7e79cc87b7b2
pkgname = touche
diff --git a/PKGBUILD b/PKGBUILD
index 55627ed62214..12e09fd800fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=touche
-pkgver=1.0.6
-pkgrel=5
+pkgver=1.0.7
+pkgrel=1
pkgdesc="The desktop application to configure Touchégg "
arch=('x86_64')
url="https://github.com/JoseExposito/touche"
@@ -11,31 +11,31 @@ makedepends=('gobject-introspection' 'meson' 'npm')
checkdepends=('appstream-glib')
provides=('libtouche.so')
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('116ecdd03070c55444f3d90263d7504a132c70ba4730a6d2fd6fd936c16b9fed')
+sha256sums=('d711512971f1a832e316ecf10515ca1845ee2597be9538419f8c7e79cc87b7b2')
build() {
- export npm_config_cache="$srcdir/npm_cache"
+ export npm_config_cache="$srcdir/npm_cache"
- cd "$pkgname-$pkgver"
- npm install
+ cd "$pkgname-$pkgver"
+ npm install
- if [[ "$XDG_CURRENT_DESKTOP" == "Pantheon" ]]; then
- arch-meson . build -Dtarget-de=elementary
- else
- arch-meson . build -Dtarget-de=gnome
- fi
+ if [[ "$XDG_CURRENT_DESKTOP" == "Pantheon" ]]; then
+ arch-meson . build -Dtarget-de=elementary
+ else
+ arch-meson . build -Dtarget-de=gnome
+ fi
- meson compile -C build
+ meson compile -C build
}
check() {
- cd "$pkgname-$pkgver"
- meson test -C build --print-errorlogs
+ cd "$pkgname-$pkgver"
+ meson test -C build --print-errorlogs
}
package() {
- cd "$pkgname-$pkgver"
- DESTDIR="$pkgdir" meson install -C build
+ cd "$pkgname-$pkgver"
+ DESTDIR="$pkgdir" meson install -C build
- ln -s "/usr/bin/com.github.joseexposito.$pkgname" "$pkgdir/usr/bin/$pkgname"
+ ln -s "/usr/bin/com.github.joseexposito.$pkgname" "$pkgdir/usr/bin/$pkgname"
}