summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-02-12 13:27:12 -0700
committerMark Wagie2021-02-12 13:27:12 -0700
commit626e2a795f40e4f5c7fa59149795a5a28427a581 (patch)
tree6f4da38579bbdbd114b2e2dc960132224f52facf
downloadaur-626e2a795f40e4f5c7fa59149795a5a28427a581.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD36
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca89f74d3a11
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = touche
+ pkgdesc = The desktop application to configure Touchégg
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/JoseExposito/touche
+ arch = x86_64
+ license = GPL3
+ checkdepends = appstream
+ checkdepends = desktop-file-utils
+ makedepends = meson
+ makedepends = npm
+ makedepends = appstream-glib
+ depends = gjs
+ depends = gtk3
+ depends = libwnck3
+ depends = touchegg
+ source = touche-1.0.2.tar.gz::https://github.com/JoseExposito/touche/archive/1.0.2.tar.gz
+ sha256sums = b1e82204bfb5e2181c8213e4fc2cd16ebd3e2da5a3fc3eaf647808ca515183ae
+
+pkgname = touche
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..53eed6879a41
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Co-Maintainer: Jeffrey Bouter <aur at kn0x dot org>
+pkgname=touche
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="The desktop application to configure Touchégg "
+arch=('x86_64')
+url="https://github.com/JoseExposito/touche"
+license=('GPL3')
+depends=('gjs' 'gtk3' 'libwnck3' 'touchegg')
+makedepends=('meson' 'npm' 'appstream-glib')
+checkdepends=('appstream' 'desktop-file-utils')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+sha256sums=('b1e82204bfb5e2181c8213e4fc2cd16ebd3e2da5a3fc3eaf647808ca515183ae')
+
+build() {
+ export npm_config_cache="$srcdir/npm_cache"
+
+ cd "$pkgname-$pkgver"
+ npm install
+
+ arch-meson -Dtarget-de=gnome . build
+ meson compile -C build
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ meson test -C build --print-errorlogs
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ DESTDIR="$pkgdir" meson install -C build
+
+ ln -s "/usr/bin/com.github.joseexposito.$pkgname" "$pkgdir/usr/bin/$pkgname"
+}