summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-02-17 08:17:11 -0700
committerMark Wagie2021-02-17 08:17:11 -0700
commiteba7938e557c608f0c997e17041a5423718d209f (patch)
treebbc16542b8004baa88ae89ba0edb056a6f845a26
parentfb0011b3ae4cdd70508d350d680783bc319c3ebe (diff)
downloadaur-eba7938e557c608f0c997e17041a5423718d209f.tar.gz
Set the Gtk version before its first import
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca89f74d3a11..30ed3eb2e69e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = touche
pkgdesc = The desktop application to configure Touchégg
pkgver = 1.0.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/JoseExposito/touche
arch = x86_64
license = GPL3
@@ -15,7 +15,9 @@ pkgbase = touche
depends = libwnck3
depends = touchegg
source = touche-1.0.2.tar.gz::https://github.com/JoseExposito/touche/archive/1.0.2.tar.gz
+ source = https://github.com/JoseExposito/touche/pull/9.patch
sha256sums = b1e82204bfb5e2181c8213e4fc2cd16ebd3e2da5a3fc3eaf647808ca515183ae
+ sha256sums = 9ef28e0efddc7d7c50d197b7c9e8f4579cbcf177331afbaffc7e95381774c1cc
pkgname = touche
diff --git a/PKGBUILD b/PKGBUILD
index e347f4d0eac0..4e3c5befe74b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=touche
pkgver=1.0.2
-pkgrel=1
+pkgrel=2
pkgdesc="The desktop application to configure Touchégg "
arch=('x86_64')
url="https://github.com/JoseExposito/touche"
@@ -9,8 +9,17 @@ license=('GPL3')
depends=('gjs' 'gtk3' 'libwnck3' 'touchegg')
makedepends=('meson' 'npm' 'appstream-glib')
checkdepends=('appstream' 'desktop-file-utils')
-source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
-sha256sums=('b1e82204bfb5e2181c8213e4fc2cd16ebd3e2da5a3fc3eaf647808ca515183ae')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz"
+ "https://github.com/JoseExposito/touche/pull/9.patch")
+sha256sums=('b1e82204bfb5e2181c8213e4fc2cd16ebd3e2da5a3fc3eaf647808ca515183ae'
+ '9ef28e0efddc7d7c50d197b7c9e8f4579cbcf177331afbaffc7e95381774c1cc')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ # Set the Gtk version before its first import
+ patch -Np1 -i "$srcdir/9.patch"
+}
build() {
export npm_config_cache="$srcdir/npm_cache"