summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-07-08 08:49:25 -0600
committerMark Wagie2021-07-08 08:49:25 -0600
commiteeeffbc439e847c6430ca62d0245a971f30cd9a1 (patch)
treea3b683be0ed5096d87a053b007c05c5efb22bad9
parentd1aa95bacda06e205d1b4926782f89598b9dddc3 (diff)
downloadaur-eeeffbc439e847c6430ca62d0245a971f30cd9a1.tar.gz
check desktop type
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD16
2 files changed, 10 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b4cb61f8dd2..726d28d1f89d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = touche
pkgdesc = The desktop application to configure Touchégg
pkgver = 1.0.6
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/JoseExposito/touche
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index 35a2781271f1..a4699fa0774f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=touche
pkgver=1.0.6
-pkgrel=1
+pkgrel=2
pkgdesc="The desktop application to configure Touchégg "
arch=('x86_64')
url="https://github.com/JoseExposito/touche"
@@ -14,22 +14,24 @@ source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
sha256sums=('116ecdd03070c55444f3d90263d7504a132c70ba4730a6d2fd6fd936c16b9fed')
build() {
- export npm_config_cache="$srcdir/npm_cache"
+ pushd "$pkgname-$pkgver"
+ npm install --cache "$srcdir/npm-cache"
+ popd
- cd "$pkgname-$pkgver"
- npm install
+ if [ "$XDG_CURRENT_DESKTOP" = "Pantheon" ]; then
+ arch-meson "$pkgname-$pkgver" build -Dtarget-de=elementary
+ else
+ arch-meson "$pkgname-$pkgver" build -Dtarget-de=gnome
+ fi
- arch-meson -Dtarget-de=gnome . build
meson compile -C build
}
check() {
- cd "$pkgname-$pkgver"
meson test -C build --print-errorlogs
}
package() {
- cd "$pkgname-$pkgver"
DESTDIR="$pkgdir" meson install -C build
ln -s "/usr/bin/com.github.joseexposito.$pkgname" "$pkgdir/usr/bin/$pkgname"