summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAwesomeHaircut2020-10-07 15:21:42 -0700
committerAwesomeHaircut2020-10-07 15:21:42 -0700
commit0d6c36e98a955b84ad76114add2474d13156409f (patch)
treef7efe8e3ea0ca5095d045ebee391d3a7ba30e237
parentf617b1adca522dfd16bd2ee60bc5c284ed5e4155 (diff)
downloadaur-0d6c36e98a955b84ad76114add2474d13156409f.tar.gz
Fixed typo.
Added .install
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--touchegg.install13
3 files changed, 16 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb3b64492931..edad8fa7d54a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = touchegg
pkgdesc = Multitouch gesture recognizer
pkgver = 2.0.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/JoseExposito/touchegg/
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 2a667fed22a0..816431e257a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=touchegg
pkgver=2.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="Multitouch gesture recognizer"
arch=('i686' 'x86_64')
url="https://github.com/JoseExposito/touchegg/"
@@ -15,7 +15,7 @@ build() {
cmake -B build -S "$pkgname-$pkgver" \
-DCMAKE_INSTALL_PREFIX=/usr \
-Wno-dev
- make -j$(nproc) -c build
+ make -C build
}
package() {
diff --git a/touchegg.install b/touchegg.install
new file mode 100644
index 000000000000..e64cd17212eb
--- /dev/null
+++ b/touchegg.install
@@ -0,0 +1,13 @@
+post_install() {
+ echo ""
+ echo "Enable & start the daemon:"
+ echo "systemctl enable --now touchegg"
+ echo ""
+}
+
+post_upgrade() {
+ echo ""
+ echo "Restart daemon:"
+ echo "systemctl daemon-reload && systemctl restart touchegg"
+ echo ""
+}