summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Krzyszkowiak2015-07-12 23:32:28 +0200
committerSebastian Krzyszkowiak2015-07-12 23:32:28 +0200
commit9acee0d41b64af2cb44a45a0d777ac46a1fd208f (patch)
tree5fcdb80ada7181f071d6058d172077b36064b435
downloadaur-9acee0d41b64af2cb44a45a0d777ac46a1fd208f.tar.gz
Initial import
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD34
-rw-r--r--touchegg-gce.desktop12
-rw-r--r--touchegg.patch11
4 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e6c3f82b122
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = touchegg-gce-git
+ pkgdesc = GUI for touchegg
+ pkgver = 1.1
+ pkgrel = 3
+ url = https://github.com/Raffarti/Touchegg-gce
+ arch = i686
+ arch = x86_64
+ license = CC-BY
+ makedepends = libx11
+ makedepends = git
+ depends = qt4
+ depends = libx11
+ depends = touchegg
+ source = git://github.com/Raffarti/Touchegg-gce.git
+ source = touchegg-gce.desktop
+ source = touchegg.patch
+ sha256sums = SKIP
+ sha256sums = abd417b6895f6a52455285b06dd3090f0fdf00bcec3f28bcf186a28b2db9db43
+ sha256sums = 49d25c678abfb81407c10e659df55f188c79dbe5808d314cac094be67fcdfa3c
+
+pkgname = touchegg-gce-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95abfffc7c5f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer : GI_Jack <iamjacksemail@hackermail.com>
+# Contributer: Kniyl <mathias@mettinger.fr>
+
+pkgname=touchegg-gce-git
+_pkgname=touchegg-gce
+pkgver=1.1
+pkgrel=3
+pkgdesc="GUI for touchegg"
+arch=('i686' 'x86_64')
+url="https://github.com/Raffarti/Touchegg-gce"
+license=('CC-BY')
+depends=('qt4' 'libx11' 'touchegg')
+makedepends=('libx11' 'git' )
+source=("git://github.com/Raffarti/Touchegg-gce.git" "touchegg-gce.desktop" "touchegg.patch")
+sha256sums=('SKIP'
+ 'abd417b6895f6a52455285b06dd3090f0fdf00bcec3f28bcf186a28b2db9db43'
+ '49d25c678abfb81407c10e659df55f188c79dbe5808d314cac094be67fcdfa3c')
+
+build() {
+ [[ -d "${srcdir}/Touchegg-build" ]] && rm -rf "${srcdir}/Touchegg-build"
+ cp -r "${srcdir}/Touchegg-gce" "${srcdir}/Touchegg-build"
+ cd "${srcdir}/Touchegg-build"
+ patch -i "${srcdir}/touchegg.patch"
+ qmake-qt4
+ make
+}
+
+package() {
+ cd "${srcdir}/Touchegg-build"
+ install -Dm755 touchegg-gce "${pkgdir}/usr/bin/touchegg-gce"
+ install -Dm644 "${srcdir}/touchegg-gce.desktop" "${pkgdir}/usr/share/applications/touchegg-gce.desktop"
+ install -d "${pkgdir}/usr/share/touchegg-gce/Dictionaries"
+ cp Dictionaries/*.qm Dictionaries/*.ts "${pkgdir}/usr/share/touchegg-gce/Dictionaries"
+}
diff --git a/touchegg-gce.desktop b/touchegg-gce.desktop
new file mode 100644
index 000000000000..0894c833cf29
--- /dev/null
+++ b/touchegg-gce.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=TouchEgg-GCE
+GenericName=MultiTouch Config
+TryExec=/opt/Touchegg-gce/touchegg-gce
+Exec=/opt/Touchegg-gce/touchegg-gce
+Terminal=false
+Icon=input-tablet
+Type=Application
+Categories=Settings;
+Comment=Configuration Tool for Touchegg multitouch.
+Name[en_US]=touchegg-gce
diff --git a/touchegg.patch b/touchegg.patch
new file mode 100644
index 000000000000..b436bcac46ea
--- /dev/null
+++ b/touchegg.patch
@@ -0,0 +1,11 @@
+--- main.cpp 2015-01-29 17:51:09.126111148 +0100
++++ main.cpp 2015-01-29 17:59:37.019553147 +0100
+@@ -31,7 +31,7 @@
+ QDialog *diag = new QDialog();
+ diag->setLayout(new QHBoxLayout());
+ QComboBox *chooser = new QComboBox(diag);
+- QDir *dir = new QDir("Dictionaries");
++ QDir *dir = new QDir("/usr/share/touchegg-gce/Dictionaries");
+ QStringList langs = dir->entryList(QStringList("[A-Z][A-Z]*.qm"), QDir::Files);
+ QStringList chopped = QStringList();
+ foreach(QString s, langs){