summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Krzyszkowiak2015-09-04 18:18:15 +0200
committerSebastian Krzyszkowiak2015-09-04 18:18:41 +0200
commitf94a6e8eead38a67282393367da1e671107592b0 (patch)
tree6e6b57335fb7e1ee07ecc8bdc67528db720653ac
parent9acee0d41b64af2cb44a45a0d777ac46a1fd208f (diff)
downloadaur-f94a6e8eead38a67282393367da1e671107592b0.tar.gz
update pkgbuild
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
-rw-r--r--touchegg-gce.desktop12
-rw-r--r--touchegg.patch11
4 files changed, 4 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6e6c3f82b122..a0a8ed174b4d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = touchegg-gce-git
pkgdesc = GUI for touchegg
pkgver = 1.1
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/Raffarti/Touchegg-gce
arch = i686
arch = x86_64
@@ -12,11 +12,7 @@ pkgbase = touchegg-gce-git
depends = libx11
depends = touchegg
source = git://github.com/Raffarti/Touchegg-gce.git
- source = touchegg-gce.desktop
- source = touchegg.patch
sha256sums = SKIP
- sha256sums = abd417b6895f6a52455285b06dd3090f0fdf00bcec3f28bcf186a28b2db9db43
- sha256sums = 49d25c678abfb81407c10e659df55f188c79dbe5808d314cac094be67fcdfa3c
pkgname = touchegg-gce-git
diff --git a/PKGBUILD b/PKGBUILD
index 95abfffc7c5f..5201a75707ff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,23 +4,20 @@
pkgname=touchegg-gce-git
_pkgname=touchegg-gce
pkgver=1.1
-pkgrel=3
+pkgrel=4
pkgdesc="GUI for touchegg"
arch=('i686' 'x86_64')
url="https://github.com/Raffarti/Touchegg-gce"
license=('CC-BY')
depends=('qt4' 'libx11' 'touchegg')
makedepends=('libx11' 'git' )
-source=("git://github.com/Raffarti/Touchegg-gce.git" "touchegg-gce.desktop" "touchegg.patch")
-sha256sums=('SKIP'
- 'abd417b6895f6a52455285b06dd3090f0fdf00bcec3f28bcf186a28b2db9db43'
- '49d25c678abfb81407c10e659df55f188c79dbe5808d314cac094be67fcdfa3c')
+source=("git://github.com/Raffarti/Touchegg-gce.git")
+sha256sums=('SKIP')
build() {
[[ -d "${srcdir}/Touchegg-build" ]] && rm -rf "${srcdir}/Touchegg-build"
cp -r "${srcdir}/Touchegg-gce" "${srcdir}/Touchegg-build"
cd "${srcdir}/Touchegg-build"
- patch -i "${srcdir}/touchegg.patch"
qmake-qt4
make
}
@@ -28,7 +25,6 @@ build() {
package() {
cd "${srcdir}/Touchegg-build"
install -Dm755 touchegg-gce "${pkgdir}/usr/bin/touchegg-gce"
- install -Dm644 "${srcdir}/touchegg-gce.desktop" "${pkgdir}/usr/share/applications/touchegg-gce.desktop"
install -d "${pkgdir}/usr/share/touchegg-gce/Dictionaries"
cp Dictionaries/*.qm Dictionaries/*.ts "${pkgdir}/usr/share/touchegg-gce/Dictionaries"
}
diff --git a/touchegg-gce.desktop b/touchegg-gce.desktop
deleted file mode 100644
index 0894c833cf29..000000000000
--- a/touchegg-gce.desktop
+++ /dev/null
@@ -1,12 +0,0 @@
-[Desktop Entry]
-Encoding=UTF-8
-Name=TouchEgg-GCE
-GenericName=MultiTouch Config
-TryExec=/opt/Touchegg-gce/touchegg-gce
-Exec=/opt/Touchegg-gce/touchegg-gce
-Terminal=false
-Icon=input-tablet
-Type=Application
-Categories=Settings;
-Comment=Configuration Tool for Touchegg multitouch.
-Name[en_US]=touchegg-gce
diff --git a/touchegg.patch b/touchegg.patch
deleted file mode 100644
index b436bcac46ea..000000000000
--- a/touchegg.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- main.cpp 2015-01-29 17:51:09.126111148 +0100
-+++ main.cpp 2015-01-29 17:59:37.019553147 +0100
-@@ -31,7 +31,7 @@
- QDialog *diag = new QDialog();
- diag->setLayout(new QHBoxLayout());
- QComboBox *chooser = new QComboBox(diag);
-- QDir *dir = new QDir("Dictionaries");
-+ QDir *dir = new QDir("/usr/share/touchegg-gce/Dictionaries");
- QStringList langs = dir->entryList(QStringList("[A-Z][A-Z]*.qm"), QDir::Files);
- QStringList chopped = QStringList();
- foreach(QString s, langs){