summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpobrn2021-10-30 19:01:23 +0200
committerpobrn2021-10-30 19:01:23 +0200
commitc5faca4d632611baf354166c10c4bc6a1892e0e2 (patch)
tree13e2fbd624ad55e2eaf00f776ca6faaa04e25130
parente8074a2f3ac55d79fec5c85276279a7d3956d4ed (diff)
downloadaur-c5faca4d632611baf354166c10c4bc6a1892e0e2.tar.gz
change versioning
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e6731ac00f67..9b09cb2ad412 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_pkgname=touchegg
pkgname=${_pkgname}-git
-pkgver=r508.f6c64bb
+pkgver=2.0.12.r3.g439d3b7
pkgrel=1
pkgdesc='Linux multi-touch gesture recognizer'
arch=('x86_64')
@@ -17,11 +17,11 @@ depends=('cairo' 'gtk3' 'pugixml' 'systemd-libs' 'libinput' 'libx11' 'libxrandr'
makedepends=('cmake' 'git')
sha256sums=('SKIP')
conflicts=("${_pkgname}")
-provides=("${_pkgname}")
+provides=("${_pkgname}=${pkgver}")
pkgver() {
cd "${_pkgname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {