summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpobrn2020-09-29 08:34:53 +0200
committerpobrn2020-09-29 08:34:53 +0200
commitca7f92820b165c86a53d6eabeab90e594ec2bc0e (patch)
tree463322c51b0e4139c54e0b13ed70a012ad7f64c3
parent64b8f996244980080099b48324e040ac60e6f3e9 (diff)
downloadaur-ca7f92820b165c86a53d6eabeab90e594ec2bc0e.tar.gz
update package()
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a1ca6927c653..53730817b91d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = touchegg-git
pkgdesc = Linux multi-touch gesture recognizer
pkgver = r322.a82d299
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/JoseExposito/touchegg
install = touchegg.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 23c7a8588d46..676da7632518 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_pkgname=touchegg
pkgname=${_pkgname}-git
pkgver=r322.a82d299
-pkgrel=2
+pkgrel=3
pkgdesc='Linux multi-touch gesture recognizer'
arch=('x86_64')
url='https://github.com/JoseExposito/touchegg'
@@ -31,9 +31,10 @@ build() {
}
package() {
- #cd "$srcdir/${_pkgname}/build"
- #DESTDIR="$pkgdir" make install
- install -D "$srcdir/build/touchegg" "$pkgdir/usr/bin/touchegg"
- install -Dm 0644 "$srcdir/${_pkgname}/installation/touchegg.conf" "$pkgdir/usr/share/touchegg/touchegg.conf"
- install -Dm 0644 "$srcdir/${_pkgname}/installation/touchegg.service" "$pkgdir/usr/lib/systemd/system/touchegg.service"
+ DESTDIR="$pkgdir" make -C build install
+
+ # /lib is a symlink to /usr/lib on most Arch systems, this
+ # workaround is needed to prevent alpm from failing with
+ # a conflict
+ [ -d "$pkgdir/lib" ] && mv "$pkgdir/lib" "$pkgdir/usr/lib"
}