summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpobrn2020-09-28 19:08:55 +0200
committerpobrn2020-09-28 19:08:55 +0200
commiteb650c5493ca6a0b8d908db06fad2d65f65d2594 (patch)
tree161ae57f5d37718711285af98cb3da6e471c908e
parente6164bc2202b2e71bb7a4dfc8de6d4cea7b8de8c (diff)
downloadaur-eb650c5493ca6a0b8d908db06fad2d65f65d2594.tar.gz
update for v2
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD38
-rw-r--r--filesystem.h23
3 files changed, 57 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0dde66c16897..96f8e4181f28 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,22 @@
-# Generated by mksrcinfo v8
-# Tue Jan 19 17:33:53 UTC 2016
pkgbase = touchegg-git
- pkgdesc = Multitouch gesture recogniser
- pkgver = r196.6bccd0d
+ pkgdesc = Linux multi-touch gesture recognizer
+ pkgver = r322.a82d299
pkgrel = 1
url = https://github.com/JoseExposito/touchegg
- arch = i686
arch = x86_64
- license = GPL
+ license = GPL3
makedepends = git
- depends = qt4
- depends = geis
+ makedepends = cmake
+ depends = libinput
+ depends = cairo
+ depends = systemd-libs
+ depends = libx11
+ depends = libxrandr
+ depends = libxtst
+ depends = pugixml
provides = touchegg
conflicts = touchegg
- source = touchegg::git+https://github.com/JoseExposito/touchegg
+ source = touchegg::git://github.com/JoseExposito/touchegg.git
md5sums = SKIP
pkgname = touchegg-git
diff --git a/PKGBUILD b/PKGBUILD
index aec0e28a071e..33ae6f5b0130 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,41 @@
#
# Touchégg : Multitouch gesture recogniser
#
-# Maintainer: Guillaume Turchini <guillaume.turchini@gmail.com>"
+# Original Maintainer: Guillaume Turchini <guillaume.turchini@gmail.com>"
_pkgname=touchegg
pkgname=${_pkgname}-git
-pkgver=r196.6bccd0d
+pkgver=r322.a82d299
pkgrel=1
-pkgdesc='Multitouch gesture recogniser'
-arch=('i686' 'x86_64')
+pkgdesc='Linux multi-touch gesture recognizer'
+arch=('x86_64')
url='https://github.com/JoseExposito/touchegg'
-license=('GPL')
-source=("${_pkgname}::git+https://github.com/JoseExposito/touchegg")
-depends=('qt4' 'geis')
-makedepends=('git')
-md5sums=('SKIP')
+license=('GPL3')
+source=("${_pkgname}::git://github.com/JoseExposito/touchegg.git" 'filesystem.h')
+depends=('libinput' 'cairo' 'systemd-libs' 'libx11' 'libxrandr' 'libxtst' 'pugixml')
+makedepends=('git' 'cmake')
+sha256sums=('SKIP' 'f58961b18b2d7b1ddf60d6784860e7c84588d991e72d7595e50267209506fb85')
conflicts=("${_pkgname}")
provides=("${_pkgname}")
pkgver() {
- cd "${_pkgname}"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd $srcdir/${_pkgname}/
- qmake-qt4
- make
+ cp "$srcdir/filesystem.h" "$srcdir/${_pkgname}/src/utils/filesystem.h"
+ cd "$srcdir/${_pkgname}"
+ mkdir build
+ cd build
+ cmake -DCMAKE_BUILD_TYPE=Release ..
+ make -j$(nproc)
}
package() {
- cd $srcdir/${_pkgname}/
- INSTALL_ROOT="$pkgdir" make install
+ #cd "$srcdir/${_pkgname}/build"
+ #DESTDIR="$pkgdir" make install
+ install -D "$srcdir/${_pkgname}/build/touchegg" "$pkgdir/usr/bin/touchegg"
+ install -Dm 0644 "$srcdir/${_pkgname}/installation/touchegg.conf" "$pkgdir/usr/share/touchegg/touchegg.conf"
+ install -Dm 0644 "$srcdir/${_pkgname}/installation/touchegg.service" "$pkgdir/usr/lib/systemd/system/touchegg.service"
}
diff --git a/filesystem.h b/filesystem.h
new file mode 100644
index 000000000000..2d096832c13a
--- /dev/null
+++ b/filesystem.h
@@ -0,0 +1,23 @@
+/**
+ * Copyright 2011 - 2020 José Expósito <jose.exposito89@gmail.com>
+ *
+ * This file is part of Touchégg.
+ *
+ * Touchégg is free software: you can redistribute it and/or modify it under the
+ * terms of the GNU General Public License as published by the Free Software
+ * Foundation, either version 3 of the License, or (at your option) any later
+ * version.
+ *
+ * Touchégg is distributed in the hope that it will be useful, but WITHOUT ANY
+ * WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR
+ * A PARTICULAR PURPOSE. See the GNU General Public License for more details.
+ *
+ * You should have received a copy of the GNU General Public License along with
+ * Touchégg. If not, see <http://www.gnu.org/licenses/>.
+ */
+#ifndef UTILS_FILESYSTEM_H_
+#define UTILS_FILESYSTEM_H_
+
+#include <filesystem>
+
+#endif // UTILS_FILESYSTEM_H_