summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Graef2015-06-13 21:33:01 +0200
committerAlbert Graef2015-06-13 21:33:01 +0200
commit4c6159dc8739710d056f72dcdda47f1f8d9d82c1 (patch)
treebf4ed996ee1c149849295ca9dbfa6813c2389992
downloadaur-4c6159dc8739710d056f72dcdda47f1f8d9d82c1.tar.gz
Initial import
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD48
-rwxr-xr-xtouchosc-editor.desktop18
-rw-r--r--touchosc-editor.install17
-rw-r--r--touchosc-editor.pngbin0 -> 14730 bytes
-rwxr-xr-xtouchosc-editor.sh5
-rw-r--r--touchosc-layout.pngbin0 -> 4282 bytes
-rw-r--r--touchosc-layout.xml11
8 files changed, 127 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1ccbff12fb58
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = touchosc-editor
+ pkgdesc = Graphical editor to create and customise layouts for TouchOSC
+ pkgver = 1.7.0
+ pkgrel = 2
+ url = http://hexler.net/
+ install = touchosc-editor.install
+ arch = any
+ license = custom
+ depends = java-runtime
+ depends = shared-mime-info
+ depends = xdg-utils
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ source = touchosc-editor.sh
+ source = touchosc-editor.png
+ source = touchosc-layout.png
+ source = touchosc-editor.desktop
+ source = touchosc-layout.xml
+ source = http://hexler.net/pub/touchosc/touchosc-editor-1.7.0-noarch.zip
+ md5sums = 995e06cdb089cb2d06e5acfbc52b08ae
+ md5sums = da2cdaa9f48b2de1294200286d465387
+ md5sums = caa18a80902f10ced5062b2407c797ee
+ md5sums = 7dbf615862f6e99e76e97ac2864531fc
+ md5sums = 68b65fc0a09478d1b055d8c5efc59e58
+ md5sums = a5ccf8b74cb031f7e475534b261d8b6a
+
+pkgname = touchosc-editor
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7f8cf863de45
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Albert Graef <aggraef@gmail.com>
+
+pkgname=touchosc-editor
+pkgver=1.7.0
+pkgrel=2
+pkgdesc="Graphical editor to create and customise layouts for TouchOSC"
+arch=('any')
+url="http://hexler.net/"
+license=('custom')
+depends=('java-runtime' 'shared-mime-info' 'xdg-utils' 'desktop-file-utils' 'hicolor-icon-theme')
+install="touchosc-editor.install"
+source=(touchosc-editor.sh
+ touchosc-editor.png
+ touchosc-layout.png
+ touchosc-editor.desktop
+ touchosc-layout.xml
+ "http://hexler.net/pub/touchosc/${pkgname}-${pkgver}-noarch.zip")
+md5sums=('995e06cdb089cb2d06e5acfbc52b08ae'
+ 'da2cdaa9f48b2de1294200286d465387'
+ 'caa18a80902f10ced5062b2407c797ee'
+ '7dbf615862f6e99e76e97ac2864531fc'
+ '68b65fc0a09478d1b055d8c5efc59e58'
+ 'a5ccf8b74cb031f7e475534b261d8b6a')
+
+package() {
+ # Installing application
+ cd $srcdir/$pkgname-$pkgver-noarch
+ install -dm755 $pkgdir/usr/share/java/
+ install -Dm644 TouchOSCEditor.jar $pkgdir/usr/share/java/
+
+ # Installing launcher
+ install -Dm755 $srcdir/touchosc-editor.sh $pkgdir/usr/bin/touchosc-editor
+
+ # Installing icons
+ install -dm755 $pkgdir/usr/share/icons/hicolor/128x128/{apps,mimetypes}
+ install -Dm644 $srcdir/touchosc-editor.png $pkgdir/usr/share/icons/hicolor/128x128/apps
+ install -Dm644 $srcdir/touchosc-layout.png $pkgdir/usr/share/icons/hicolor/128x128/mimetypes
+
+ # Installing menu item
+ install -Dm644 $srcdir/touchosc-editor.desktop $pkgdir/usr/share/applications/touchosc-editor.desktop
+
+ # Installing mimetype
+ install -Dm644 $srcdir/touchosc-layout.xml $pkgdir/usr/share/mime/packages/touchosc-layout.xml
+
+ # Installing layouts
+ install -dm755 $pkgdir/usr/share/doc/touchosc-editor/
+ install -Dm644 layouts/* $pkgdir/usr/share/doc/touchosc-editor
+}
diff --git a/touchosc-editor.desktop b/touchosc-editor.desktop
new file mode 100755
index 000000000000..4c15a900d14d
--- /dev/null
+++ b/touchosc-editor.desktop
@@ -0,0 +1,18 @@
+[Desktop Entry]
+Comment[en_US]=
+Comment=
+Exec=touchosc-editor %f
+Icon=touchosc-editor
+MimeType=application/touchosc
+Name=TouchOSC Editor
+Name[en_US]=TouchOSC Editor
+Path=
+StartupNotify=false
+Terminal=false
+TerminalOptions=
+Type=Application
+Categories=AudioVideo;Music;Utility;
+X-DBUS-ServiceName=
+X-DBUS-StartupType=
+X-KDE-SubstituteUID=false
+X-KDE-Username=
diff --git a/touchosc-editor.install b/touchosc-editor.install
new file mode 100644
index 000000000000..078249bda7f7
--- /dev/null
+++ b/touchosc-editor.install
@@ -0,0 +1,17 @@
+post_install() {
+ echo "Updating icon cache..."
+ gtk-update-icon-cache -q /usr/share/icons/hicolor > /dev/null
+ echo "Updating desktop database..."
+ update-desktop-database -q > /dev/null
+ echo "Updating mime database..."
+ update-mime-database /usr/share/mime/ > /dev/null
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+
diff --git a/touchosc-editor.png b/touchosc-editor.png
new file mode 100644
index 000000000000..60bf4bbd2525
--- /dev/null
+++ b/touchosc-editor.png
Binary files differ
diff --git a/touchosc-editor.sh b/touchosc-editor.sh
new file mode 100755
index 000000000000..87b83e5e0c58
--- /dev/null
+++ b/touchosc-editor.sh
@@ -0,0 +1,5 @@
+#! /bin/bash
+
+# Launch the TouchOSC editor. NOTE: While we do pass arguments on the command
+# line, at present the Java application just ignores these on Linux.
+exec java -jar /usr/share/java/TouchOSCEditor.jar "$@"
diff --git a/touchosc-layout.png b/touchosc-layout.png
new file mode 100644
index 000000000000..2f1b3d0d1b75
--- /dev/null
+++ b/touchosc-layout.png
Binary files differ
diff --git a/touchosc-layout.xml b/touchosc-layout.xml
new file mode 100644
index 000000000000..a28981f2add3
--- /dev/null
+++ b/touchosc-layout.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<mime-info xmlns="http://www.freedesktop.org/standards/shared-mime-info">
+ <mime-type type="application/touchosc">
+ <comment>TouchOSC layout</comment>
+ <comment xml:lang="de">TouchOSC-Layout</comment>
+ <comment xml:lang="fr">Maquette de TouchOSC</comment>
+ <sub-class-of type="application/zip"/>
+ <generic-icon name="touchosc-layout"/>
+ <glob pattern="*.touchosc"/>
+ </mime-type>
+</mime-info>