summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2019-05-05 07:52:33 -0600
committeryochananmarqos2019-05-05 07:52:33 -0600
commit6935c825d15b26dc24cc3868b00daccf7f182d15 (patch)
treefae688f59d1878e723642d3e277af3d492047cd2
parent51f9571640abfbfd1a0404b92cf72e16ad121e30 (diff)
downloadaur-6935c825d15b26dc24cc3868b00daccf7f182d15.tar.gz
added missing dependency, fixed permissions & other fixes
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD7
2 files changed, 6 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6352a9cf5752..71499c752fb6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = touchpad-indicator-git
pkgdesc = An indicator for the touchpad
pkgver = r95.48ab61a
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/atareao/Touchpad-Indicator
arch = any
license = GPL3
@@ -9,6 +9,7 @@ pkgbase = touchpad-indicator-git
depends = gdk-pixbuf2
depends = libappindicator-gtk3
depends = libnotify
+ depends = lsb-release
depends = gconf
depends = librsvg
depends = python-xlib
diff --git a/PKGBUILD b/PKGBUILD
index 55c15176965d..98bedd4fe7d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Mark Wagie <yochanan dot marqos at gmail dot com>
pkgname=touchpad-indicator-git
pkgver=r95.48ab61a
-pkgrel=1
+pkgrel=2
pkgdesc="An indicator for the touchpad"
arch=('any')
url="https://github.com/atareao/Touchpad-Indicator"
license=('GPL3')
-depends=('gtk3' 'gdk-pixbuf2' 'libappindicator-gtk3' 'libnotify' 'gconf' 'librsvg' 'python-xlib' 'python-pyudev' 'python-dbus' 'xorg-xinput')
+depends=('gtk3' 'gdk-pixbuf2' 'libappindicator-gtk3' 'libnotify' 'lsb-release' 'gconf' 'librsvg' 'python-xlib' 'python-pyudev' 'python-dbus' 'xorg-xinput')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
source=("git+https://github.com/atareao/Touchpad-Indicator.git")
@@ -20,8 +20,9 @@ pkgver() {
package() {
cd "Touchpad-Indicator"
install -Dm755 "bin/${pkgname%-git}" "$pkgdir/usr/bin/${pkgname%-git}"
+ install -Dm644 debian/changelog "$pkgdir/usr/share/${pkgname%-git}/changelog"
+ install -Dm755 src/*.py "$pkgdir/usr/share/${pkgname%-git}"
install -d $pkgdir/usr/share/{touchpad-indicator/icons,glib-2.0/schemas}
- install -Dm644 src/*.py "$pkgdir/usr/share/${pkgname%-git}"
install -Dm644 data/icons/*.svg "$pkgdir/usr/share/${pkgname%-git}/icons"
install -Dm644 data/schemas/*.xml $pkgdir/usr/share/glib-2.0/schemas
install -Dm755 data/00_check_touchpad_status $pkgdir/etc/pm/sleep.d/00_check_touchpad_status