summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2019-02-06 18:28:53 -0700
committeryochananmarqos2019-02-06 18:28:53 -0700
commite2827f618fdc0f1ca449ff6f37deef076fedf9ae (patch)
tree5840c77b5352a30d6e1c88548d7ddca7137e4929
downloadaur-e2827f618fdc0f1ca449ff6f37deef076fedf9ae.tar.gz
initial upload
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD39
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..378b683ca8a8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = touchpad-indicator-git
+ pkgdesc = An indicator for the touchpad
+ pkgver = r95.48ab61a
+ pkgrel = 1
+ url = https://www.atareao.es
+ arch = any
+ license = GPL3
+ depends = gtk3
+ depends = gdk-pixbuf2
+ depends = libappindicator-gtk3
+ depends = libnotify
+ depends = gconf
+ depends = librsvg
+ depends = python-xlib
+ depends = python-pyudev
+ depends = python-dbus
+ depends = xorg-xinput
+ provides = touchpad-indicator
+ conflicts = touchpad-indicator-bzr
+ source = git+https://github.com/atareao/Touchpad-Indicator.git
+ md5sums = SKIP
+
+pkgname = touchpad-indicator-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b05285ab3b1c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+pkgname=touchpad-indicator-git
+_pkgname=touchpad-indicator
+_gitname=Touchpad-Indicator
+pkgver=r95.48ab61a
+pkgrel=1
+pkgdesc="An indicator for the touchpad"
+arch=('any')
+url="https://www.atareao.es"
+license=('GPL3')
+depends=('gtk3' 'gdk-pixbuf2' 'libappindicator-gtk3' 'libnotify' 'gconf' 'librsvg' 'python-xlib' 'python-pyudev' 'python-dbus' 'xorg-xinput')
+provides=("$_pkgname")
+conflicts=("$_pkgname-bzr")
+source=("git+https://github.com/atareao/$_gitname.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$_gitname"
+ install -Dm755 bin/$_pkgname $pkgdir/usr/bin/$_pkgname
+ install -Dm644 debian/changelog $pkgdir/usr/share/$_pkgname/changelog
+ install -Dm644 src/*.py $pkgdir/usr/share/$_pkgname
+ install -d $pkgdir/usr/share/{$_pkgname/icons,glib-2.0/schemas}
+ install -Dm644 data/icons/*.svg $pkgdir/usr/share/$_pkgname/icons
+ install -Dm644 data/schemas/*.xml $pkgdir/usr/share/glib-2.0/schemas
+ install -Dm755 data/00_check_touchpad_status $pkgdir/etc/pm/sleep.d/00_check_touchpad_status
+ install -Dm755 data/00_check_touchpad_status_systemd $pkgdir/usr/lib/systemd/system-sleep/00_check_touchpad_status_systemd
+ install -Dm644 data/$_pkgname.desktop $pkgdir/usr/share/applications/$_pkgname.desktop
+ install -Dm644 data/$_pkgname-autostart.desktop $pkgdir/usr/share/$_pkgname/$_pkgname-autostart.desktop
+ install -Dm644 data/icons/$_pkgname.svg $pkgdir/usr/share/icons/hicolor/scalable/apps/$_pkgname.svg
+ for icon_size in 8 16 32 48 96 128 192 256 512 1024; do
+ icons_dir=/usr/share/icons/hicolor/${icon_size}x${icon_size}/apps
+ install -d $pkgdir/$icons_dir
+ install -Dm644 data/icons/${icon_size}x${icon_size}/$_pkgname.png $pkgdir$icons_dir/$_pkgname.png
+ done
+}