summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryochananmarqos2019-04-29 09:14:24 -0600
committeryochananmarqos2019-04-29 09:14:24 -0600
commitf2cdd737b441bdb10b06470f5d6c2f8781b8d4b4 (patch)
tree93e58e8c26ca3d44f1d57ef4e08a17801257d9c2
parentd0a30c3da79d04d2ddf5ea571a3ee74030f95b92 (diff)
downloadaur-f2cdd737b441bdb10b06470f5d6c2f8781b8d4b4.tar.gz
PKGBUILD tweaks
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD33
2 files changed, 18 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 702d559f4b61..6352a9cf5752 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -2,7 +2,7 @@ pkgbase = touchpad-indicator-git
pkgdesc = An indicator for the touchpad
pkgver = r95.48ab61a
pkgrel = 1
- url = https://www.atareao.es/aplicacion/touchpad-indicator-para-ubuntu
+ url = https://github.com/atareao/Touchpad-Indicator
arch = any
license = GPL3
depends = gtk3
@@ -16,9 +16,9 @@ pkgbase = touchpad-indicator-git
depends = python-dbus
depends = xorg-xinput
provides = touchpad-indicator
- conflicts = touchpad-indicator-bzr
+ conflicts = touchpad-indicator
source = git+https://github.com/atareao/Touchpad-Indicator.git
- md5sums = SKIP
+ sha256sums = SKIP
pkgname = touchpad-indicator-git
diff --git a/PKGBUILD b/PKGBUILD
index e71df79535ee..b15b27dfffb6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,37 @@
# Maintainer: Mark Wagie <yochanan dot marqos at gmail dot com>
pkgname=touchpad-indicator-git
-_pkgname=touchpad-indicator
-_gitname=Touchpad-Indicator
pkgver=r95.48ab61a
pkgrel=1
pkgdesc="An indicator for the touchpad"
arch=('any')
-url="https://www.atareao.es/aplicacion/touchpad-indicator-para-ubuntu"
+url="https://github.com/atareao/Touchpad-Indicator"
license=('GPL3')
depends=('gtk3' 'gdk-pixbuf2' 'libappindicator-gtk3' 'libnotify' 'gconf' 'librsvg' 'python-xlib' 'python-pyudev' 'python-dbus' 'xorg-xinput')
-provides=("$_pkgname")
-conflicts=("$_pkgname-bzr")
-source=("git+https://github.com/atareao/$_gitname.git")
-md5sums=('SKIP')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=("git+https://github.com/atareao/Touchpad-Indicator.git")
+sha256sums=('SKIP')
pkgver() {
- cd "$_gitname"
+ cd "Touchpad-Indicator"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd "$_gitname"
- install -Dm755 bin/$_pkgname $pkgdir/usr/bin/$_pkgname
- install -Dm644 debian/changelog $pkgdir/usr/share/$_pkgname/changelog
- install -Dm644 src/*.py $pkgdir/usr/share/$_pkgname
- install -d $pkgdir/usr/share/{$_pkgname/icons,glib-2.0/schemas}
- install -Dm644 data/icons/*.svg $pkgdir/usr/share/$_pkgname/icons
+ cd "Touchpad-Indicator"
+ install -Dm755 "bin/${pkgname%-git}" "$pkgdir/usr/bin/${pkgname%-git}"
+ install -Dm644 src/*.py "$pkgdir/usr/share/${pkgname%-git}"
+ install -d $pkgdir/usr/share/{touchpad-indicator/icons,glib-2.0/schemas}
+ install -Dm644 data/icons/*.svg "$pkgdir/usr/share/${pkgname%-git}/icons"
install -Dm644 data/schemas/*.xml $pkgdir/usr/share/glib-2.0/schemas
install -Dm755 data/00_check_touchpad_status $pkgdir/etc/pm/sleep.d/00_check_touchpad_status
install -Dm755 data/00_check_touchpad_status_systemd $pkgdir/usr/lib/systemd/system-sleep/00_check_touchpad_status_systemd
- install -Dm644 data/$_pkgname.desktop $pkgdir/usr/share/applications/$_pkgname.desktop
- install -Dm644 data/$_pkgname-autostart.desktop $pkgdir/usr/share/$_pkgname/$_pkgname-autostart.desktop
- install -Dm644 data/icons/$_pkgname.svg $pkgdir/usr/share/icons/hicolor/scalable/apps/$_pkgname.svg
+ install -Dm644 "data/${pkgname%-git}.desktop" "$pkgdir/usr/share/applications/${pkgname%-git}.desktop"
+ install -Dm644 "data/${pkgname%-git}-autostart.desktop" "$pkgdir/usr/share/${pkgname%-git}/${pkgname%-git}-autostart.desktop"
+ install -Dm644 "data/icons/${pkgname%-git}.svg" "$pkgdir/usr/share/icons/hicolor/scalable/apps/${pkgname%-git}.svg"
for icon_size in 8 16 32 48 96 128 192 256 512 1024; do
icons_dir=/usr/share/icons/hicolor/${icon_size}x${icon_size}/apps
install -d $pkgdir/$icons_dir
- install -Dm644 data/icons/${icon_size}x${icon_size}/$_pkgname.png $pkgdir$icons_dir/$_pkgname.png
+ install -Dm644 "data/icons/${icon_size}x${icon_size}/${pkgname%-git}.png" "$pkgdir$icons_dir/${pkgname%-git}.png"
done
}