summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTheo J.A. de Vries2015-07-30 10:35:42 +0200
committerTheo J.A. de Vries2015-07-30 10:35:42 +0200
commit620fffa126b3a5d3b16f864cbd9ba6bb4ec8997c (patch)
treeceb2a97b8ed4efa5bb12d25bb4756aaa440e2e18
downloadaur-touchpad-toggle.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD43
-rwxr-xr-xtouchpad-toggle.sh7
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..112936ae9232
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = touchpad-toggle
+ pkgdesc = Script to toggle the touchpad; see https://wiki.archlinux.org/index.php/Touchpad_Synaptics#Software_toggle. Use desktop environment to set keyboard shortcut.
+ pkgver = 1
+ pkgrel = 1
+ arch = any
+ license = Apache
+ depends = bash
+ depends = xf86-input-synaptics
+ provides = touchpad-toggle
+ conflicts = touchpad-toggle
+ source = touchpad-toggle.sh
+ md5sums = b691e7dbf1c850900120624dbe40e019
+
+pkgname = touchpad-toggle
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..976ce6342fc7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Theo J.A. de Vries <t.j.a.devries(at)gmail(dot)com>
+
+# for customization
+_pkgname=touchpad-toggle
+_ext=
+_basedir=/usr/bin
+# note: depends=() needs separate customization
+
+pkgname=${_pkgname}${_ext}
+pkgver=1
+pkgrel=1
+pkgdesc="Script to toggle the touchpad; see https://wiki.archlinux.org/index.php/Touchpad_Synaptics#Software_toggle. Use desktop environment to set keyboard shortcut."
+arch=("any")
+#url="https://bitbucket.org/"
+license=("Apache")
+groups=()
+depends=("bash" "xf86-input-synaptics")
+#makedepends=("git")
+optdepends=()
+provides=("touchpad-toggle")
+conflicts=("touchpad-toggle")
+#backup=()
+#options=()
+#install=
+source=(
+ "touchpad-toggle.sh"
+ )
+noextract=()
+#md5sums=() #generate with 'makepkg -g >> PKGBUILD'
+
+build() {
+ msg "Nothing to build really.."
+}
+
+package() {
+ # cd "$srcdir/$_gitname-build"
+
+ msg "Installing script file"
+ install -m755 -d ${pkgdir}${_basedir}
+ install -m655 touchpad-toggle.sh ${pkgdir}${_basedir}/touchpad-toggle.sh
+}
+
+md5sums=('b691e7dbf1c850900120624dbe40e019')
diff --git a/touchpad-toggle.sh b/touchpad-toggle.sh
new file mode 100755
index 000000000000..913e87688915
--- /dev/null
+++ b/touchpad-toggle.sh
@@ -0,0 +1,7 @@
+#!/bin/bash
+
+# Script to toggle the touchpad
+# See https://wiki.archlinux.org/index.php/Touchpad_Synaptics#Software_toggle
+# Use desktop environment to set keyboard shortcut.
+
+synclient TouchpadOff=$(synclient -l | grep -c 'TouchpadOff.*=.*0')