aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBettehem2018-07-31 19:38:40 +0300
committerBettehem2018-07-31 19:38:40 +0300
commit9ab76f3a8baa1c41894cc631788b674a7c1928d2 (patch)
treea3fb3877b902f0e77073a80b60fbe99260a90021
downloadaur-9ab76f3a8baa1c41894cc631788b674a7c1928d2.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
-rw-r--r--README.md9
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..55e7367a9104
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = touchpad_config
+ pkgdesc = A simple tool that uses xinput to enable Tap to click and natural scrolling on a touchpad
+ pkgver = 1.0
+ pkgrel = 1
+ arch = x86_64
+ license = GPL-3
+ makedepends = gcc
+ depends = xorg-xinput
+ provides = touchpad_config
+ source = touchpad_config::git+https://gitlab.com/Bettehem/touchpad_config.git
+ md5sums = SKIP
+
+pkgname = touchpad_config
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6f2501416458
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Chris Mustola <chris.mustola at gmail dot com>
+
+pkgname=touchpad_config
+pkgver=1.0
+pkgrel=1
+pkgdesc="A simple tool that uses xinput to enable Tap to click and natural scrolling on a touchpad"
+arch=('x86_64')
+license=('GPL-3')
+depends=('xorg-xinput')
+makedepends=('gcc')
+provides=('touchpad_config')
+source=("touchpad_config::git+https://gitlab.com/Bettehem/touchpad_config.git")
+md5sums=('SKIP')
+
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make PREFIX="/usr" DESTDIR="$pkgdir" install
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..4a1dfd25c422
--- /dev/null
+++ b/README.md
@@ -0,0 +1,9 @@
+# touchpad_config
+
+This is a PKGBUILD for Arch Linux.
+It installs [touchpad_config](https://gitlab.com/Bettehem/touchpad_config) on to your system.
+
+### How to use:
+clone this repo: ```git clone https://gitlab.com/Bettehem/touchpad_config-git.git```
+change directory to repo: ```cd touchpad_config-git```
+make package and install: ```makepkg -si```