summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwenLiangcan2015-06-09 00:00:58 +0800
committerwenLiangcan2015-06-09 00:00:58 +0800
commit983802ac054d43e0af93aabbc838f2962855d31a (patch)
treece1814288f59dd2852e8aad6ab4b508ccc6ff4d6
downloadaur-983802ac054d43e0af93aabbc838f2962855d31a.tar.gz
tower-of-guns 1414520623-1.
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD61
-rw-r--r--tower-of-guns.desktop12
-rw-r--r--tower-of-guns.install11
-rw-r--r--tower-of-guns.sh15
5 files changed, 124 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8ea579339bf2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = tower-of-guns
+ pkgdesc = Tower of Guns is a fast-paced, first-person shooter for the twitch gamer, featuring a few randomized elements to keep each playthrough fresh.
+ pkgver = 1414520623
+ pkgrel = 1
+ url = http://www.towerofguns.com/
+ install = tower-of-guns.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = openal
+ depends = libvorbis
+ depends = gcc-libs
+ depends = libgl
+ depends = libxext
+ noextract = TowerOfGuns_Linux_1414520623.sh
+ options = !strip
+ source = tower-of-guns.desktop
+ source = tower-of-guns.sh
+ source = hib://TowerOfGuns_Linux_1414520623.sh
+ md5sums = c5848b7ef54506f7538d26e5335609c4
+ md5sums = 09390a3d0f46508537e8d5d0ab8f8297
+ md5sums = 44878e651e2e06461262ce5cac5e8d12
+
+pkgname = tower-of-guns
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..52aebe7f5cd9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Maintainer: wenLiangcan <boxeed at gmail dot com>
+
+pkgname=tower-of-guns
+pkgver=1414520623
+pkgrel=1
+pkgdesc='Tower of Guns is a fast-paced, first-person shooter for the twitch gamer, featuring a few randomized elements to keep each playthrough fresh.'
+arch=('i686' 'x86_64')
+url='http://www.towerofguns.com/'
+license=('custom')
+if [ "$CARCH" = "x86_64" ]; then
+ depends=('lib32-openal' 'lib32-libvorbis' 'lib32-gcc-libs' 'lib32-libgl' 'lib32-libxext')
+else
+ depends=('openal' 'libvorbis' 'gcc-libs' 'libgl' 'libxext')
+fi
+options=('!strip')
+_gamepkg="TowerOfGuns_Linux_${pkgver}.sh"
+source=("${pkgname}.desktop"
+ "${pkgname}.sh"
+ "hib://${_gamepkg}")
+md5sums=('c5848b7ef54506f7538d26e5335609c4'
+ '09390a3d0f46508537e8d5d0ab8f8297'
+ '44878e651e2e06461262ce5cac5e8d12')
+noextract=("${_gamepkg}")
+install=$pkgname.install
+# You can download the Humble Indie Bundle file manually, or you can configure
+# DLAGENTS in makepkg.conf to auto-download.
+#
+# For example, to use hib-dlagent to download files set something like this in
+# your makepkg.conf (change/add -k and add -u/-p to your needs):
+# DLAGENTS=('hib::/usr/bin/hib-dlagent -k 1a2b3c -o %o $(echo %u | cut -c 7-)')
+#
+# To auto-search through a directory containing Humble Bundle downloads, you
+# could set:
+# DLAGENTS=('hib::/usr/bin/find /path/to/downloads -name $(echo %u | cut -c 7-) -exec ln -s \{\} %o \; -quit')
+DLAGENTS+=('hib::/usr/bin/echo "Could not find %u. Download manually to \"$(pwd)\" or setup hib:// DLAGENT in /etc/makepkg.conf."; echo "Read this PKGBUILD for more info."; exit 1')
+PKGEXT='.pkg.tar'
+
+build(){
+ bsdtar xzf "${_gamepkg}"
+ rm -rf scripts meta
+}
+
+package(){
+ install -dm755 "${pkgdir}/opt/${pkgname}"
+
+ cd "${srcdir}/data/noarch"
+ find . -type f -exec install -Dm644 {} \
+ "${pkgdir}/opt/${pkgname}/{}" \;
+
+ cd "${srcdir}/data/x86"
+ rm TowerOfGuns.sh
+ find . -type f -exec install -Dm644 {} \
+ "${pkgdir}/opt/${pkgname}/{}" \;
+
+ chmod 755 "${pkgdir}/opt/tower-of-guns/Binaries/Linux/UDKGame-Linux"
+
+ install -Dm644 "${srcdir}/${pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ install -Dm755 "${srcdir}/${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
+}
diff --git a/tower-of-guns.desktop b/tower-of-guns.desktop
new file mode 100644
index 000000000000..3c3d8d8dfa74
--- /dev/null
+++ b/tower-of-guns.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Encoding=UTF-8
+Value=1.0
+Type=Application
+Name=Tower of Guns
+GenericName=Tower of Guns
+Comment=Tower of Guns
+Icon=/opt/tower-of-guns/TowerOfGunsIcon.png
+Exec="/usr/bin/tower-of-guns"
+Categories=Game;
+Path=/opt/tower-of-guns
+
diff --git a/tower-of-guns.install b/tower-of-guns.install
new file mode 100644
index 000000000000..bb78cb06095f
--- /dev/null
+++ b/tower-of-guns.install
@@ -0,0 +1,11 @@
+post_install() {
+ cat << EOF
+
+ Your game datas will be saved at:
+ ~/.TowerOfGuns/Binaries/Linux
+EOF
+}
+
+post_upgrade() {
+ post_install
+}
diff --git a/tower-of-guns.sh b/tower-of-guns.sh
new file mode 100644
index 000000000000..05a426690f35
--- /dev/null
+++ b/tower-of-guns.sh
@@ -0,0 +1,15 @@
+#!/bin/sh
+
+DDIR="${HOME}/.TowerOfGuns"
+BDIR="/opt/tower-of-guns/Binaries/Linux"
+
+if [ ! -d ${DDIR} ]; then
+ mkdir -p "${DDIR}/Binaries/Linux"
+ ln -fs "${BDIR}/steam_appid.txt" "${DDIR}/Binaries/Linux/steam_appid.txt"
+ ln -fs "${BDIR}/lib" "${DDIR}/Binaries/Linux/lib"
+ ln -fs "/opt/tower-of-guns/UDKGame" "${DDIR}/UDKGame"
+ ln -fs "/opt/tower-of-guns/Engine" "${DDIR}/Engine"
+fi
+
+cd "${DDIR}/Binaries/Linux"
+exec "${BDIR}/UDKGame-Linux" $@