summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMoviuro2018-07-23 22:39:37 +0200
committerMoviuro2018-07-23 22:39:37 +0200
commit665c6387ca7069c15095f568950e5838f7efbaae (patch)
tree2cb78fcc50e7944d568b906052d10ac1f2786787
downloadaur-665c6387ca7069c15095f568950e5838f7efbaae.tar.gz
towerfall-hib: first introduction to AUR
-rw-r--r--.SRCINFO52
-rw-r--r--PKGBUILD56
2 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..24f3bd906fb2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,52 @@
+pkgbase = towerfall-hib
+ pkgdesc = Towerfall is an archery combat platformer for up to 4 players.
+ pkgver = 20160721
+ pkgrel = 1
+ url = http://www.towerfall-game.com/
+ arch = i686
+ arch = x86_64
+ license = custom:commercial
+ depends = dbus
+ depends = expat
+ depends = flac
+ depends = icu
+ depends = libasyncns
+ depends = libdrm
+ depends = libedit
+ depends = libelf
+ depends = libffi
+ depends = libgcrypt
+ depends = libglvnd
+ depends = libgpg-error
+ depends = libogg
+ depends = libpulse
+ depends = libsndfile
+ depends = libsystemd
+ depends = libvorbis
+ depends = libx11
+ depends = libxau
+ depends = libxcb
+ depends = libxcursor
+ depends = libxdamage
+ depends = libxdmcp
+ depends = libxext
+ depends = libxfixes
+ depends = libxi
+ depends = libxinerama
+ depends = libxml2
+ depends = libxrandr
+ depends = libxrender
+ depends = libxshmfence
+ depends = libxxf86vm
+ depends = llvm-libs
+ depends = lm_sensors
+ depends = lz4
+ depends = mesa
+ depends = ncurses
+ depends = xz
+ depends = zlib
+ source = hib://towerfall-07212016-bin
+ sha256sums = 8378611a675dc31157d98745d4c71f14ff1655ed573710288cf1329ea80078b4
+
+pkgname = towerfall-hib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95f7c00f610f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Maintainer: Moviuro <moviuro+aur at gmail dot com>
+
+_pkgname=towerfall
+pkgname=${_pkgname}-hib
+_yearpkgver=2016
+_restpkgver=0721
+pkgver="${_yearpkgver}${_restpkgver}"
+_retard_pkgver=${_restpkgver}${_yearpkgver}
+pkgrel=1
+pkgdesc="Towerfall is an archery combat platformer for up to 4 players."
+arch=("i686" "x86_64")
+url="http://www.towerfall-game.com/"
+depends=(dbus expat flac icu libasyncns libdrm libedit libelf libffi libgcrypt
+ libglvnd libgpg-error libogg libpulse libsndfile libsystemd libvorbis
+ libx11 libxau libxcb libxcursor libxdamage libxdmcp libxext libxfixes
+ libxi libxinerama libxml2 libxrandr libxrender libxshmfence libxxf86vm
+ llvm-libs lm_sensors lz4 mesa ncurses xz zlib)
+license=("custom:commercial")
+source=("hib://${_pkgname}-${_retard_pkgver}-bin")
+sha256sums=("8378611a675dc31157d98745d4c71f14ff1655ed573710288cf1329ea80078b4")
+
+# Disable compression of the package
+PKGEXT='.pkg.tar'
+
+package() {
+ # Data
+ mkdir -p "$pkgdir/opt/$pkgname/data/"
+ # Hardlink files to save the disk space and time spent copying them (they are large)
+ cp -Ral -t "$pkgdir/opt/$pkgname/data/" "$srcdir/data/"*
+ find "$pkgdir/opt/$pkgname/data" -type d -print0 | xargs -0 chmod 755
+ find "$pkgdir/opt/$pkgname/data" -type f -print0 | xargs -0 chmod 644
+
+ # Binaries
+ chmod +x "$pkgdir/opt/$pkgname/data/TowerFall.bin.x86"
+ chmod +x "$pkgdir/opt/$pkgname/data/TowerFall.bin.x86_64"
+
+ # And now, welcome stupid
+ # The game simply won't run if you don't allow +r on those
+ chmod -R a+w "$pkgdir/opt/$pkgname/data/Content/Atlas/"*.png
+ chmod -R a+w "$pkgdir/opt/$pkgname/data/Content/SFX/"*.wav
+
+ #
+ # System integration
+ #
+
+ # /bin
+ install -m755 -d "$pkgdir/usr/bin/"
+ ln -s "/opt/$pkgname/data/TowerFall.bin.x86_64" "$pkgdir/usr/bin/$pkgname"
+
+ # License
+ # None to be found in the archive
+
+ # Icon
+ install -m755 -d "$pkgdir/usr/share/pixmaps/"
+ ln -s "/opt/$pkgname/data/TowerFall.png" "$pkgdir/usr/share/pixmaps/${pkgname}.png"
+}