summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn ShaggyTwoDope Jenkins2015-08-09 23:42:07 -0700
committerJohn ShaggyTwoDope Jenkins2015-08-09 23:42:07 -0700
commit79ad5009b2b7b1981c51f0865d6801779f1e5886 (patch)
treed28a43c6e16176eb837ff4382f2421561cce6623
downloadaur-79ad5009b2b7b1981c51f0865d6801779f1e5886.tar.gz
init
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD42
-rw-r--r--tox-weechat-git.install5
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..73ab2ea654e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = tox-weechat-git
+ pkgdesc = Tox protocol plugin for WeeChat
+ pkgver = r255.ed96d36
+ pkgrel = 1
+ url = https://github.com/haavardp/tox-weechat
+ install = tox-weechat-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = cmake
+ depends = tox-git
+ depends = weechat>=1.0.1
+ provides = tox-weechat
+ conflicts = tox-weechat
+ source = tox-weechat-git::git+https://github.com/haavardp/tox-weechat.git
+ md5sums = SKIP
+
+pkgname = tox-weechat-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cfbfd41b457f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Johnathan Jenkins <twodopeshaggy@gmail.com>
+# Contributor: HÃ¥vard Pettersson <mail@haavard.me>
+
+_pkgname=tox-weechat
+pkgname=tox-weechat-git
+pkgver=r255.ed96d36
+pkgrel=1
+
+pkgdesc='Tox protocol plugin for WeeChat'
+arch=('i686' 'x86_64')
+url='https://github.com/haavardp/tox-weechat'
+license=('GPL3')
+
+depends=(
+ 'tox-git'
+ 'weechat>=1.0.1'
+)
+makedepends=('git' 'cmake')
+
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+
+source=("${pkgname}::git+https://github.com/haavardp/tox-weechat.git")
+md5sums=('SKIP')
+
+install="${pkgname}.install"
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR="${pkgdir}/" install
+}
diff --git a/tox-weechat-git.install b/tox-weechat-git.install
new file mode 100644
index 000000000000..915c1a2983df
--- /dev/null
+++ b/tox-weechat-git.install
@@ -0,0 +1,5 @@
+post_install() {
+ echo "Load Tox-WeeChat in WeeChat manually with '/plugin load /usr/lib/weechat/plugins/tox.so'"
+ echo 'It should load automatically.'
+}
+