summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorZhang Hai2015-12-04 12:22:47 +0800
committerZhang Hai2015-12-04 12:23:11 +0800
commit9538cbef05f8067803e27b24daed32e563118e39 (patch)
treedf72b737c0d2a5449c6ecdc62efbb5999ebdf779
parent5b0498fa41a2a49f8e1268e6e4b90a1ebc64d375 (diff)
downloadaur-9538cbef05f8067803e27b24daed32e563118e39.tar.gz
Add backup; Tidy a bit.
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD13
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index edda5bfd33f1..5e883e089015 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -7,6 +7,7 @@ pkgbase = tp-battery-mode
arch = i686
license = GPL3
depends = tpacpi-bat
+ backup = etc/tp-battery-mode.conf
source = https://github.com/DreaminginCodeZH/tp-battery-mode/archive/v1.2.0.tar.gz
sha256sums = 8186699a537c7675400526c670e09b0693637a44bf31beb23fd8be33e2eb5a0a
diff --git a/PKGBUILD b/PKGBUILD
index 47ead61af93e..f9f665b47e3c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,19 @@
pkgname=tp-battery-mode
pkgver=1.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="Module to manage the battery mode (lifetime/runtime) of your Thinkpad"
url="https://github.com/DreaminginCodeZH/tp-battery-mode"
arch=('x86_64' 'i686')
license=('GPL3')
depends=('tpacpi-bat')
-source=(https://github.com/DreaminginCodeZH/${pkgname}/archive/v${pkgver}.tar.gz)
+backup=("etc/${pkgname}.conf")
+source=("https://github.com/DreaminginCodeZH/${pkgname}/archive/v${pkgver}.tar.gz")
sha256sums=('8186699a537c7675400526c670e09b0693637a44bf31beb23fd8be33e2eb5a0a')
package() {
- cd "$srcdir/${pkgname}-${pkgver}"
- install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
- install -Dm644 "${pkgname}.conf" "${pkgdir}/etc/${pkgname}.conf"
- install -Dm644 "${pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
+ cd "$srcdir/${pkgname}-${pkgver}"
+ install -Dm755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "${pkgname}.conf" "${pkgdir}/etc/${pkgname}.conf"
+ install -Dm644 "${pkgname}.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
}