summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Mohr2020-04-22 20:21:27 +0200
committerAlexander Mohr2020-04-22 20:21:27 +0200
commitf7207b5036a5821ea4d799d051d820ffcc35a840 (patch)
tree48d34c097421de706106c96bd78fbde24907def8
downloadaur-f7207b5036a5821ea4d799d051d820ffcc35a840.tar.gz
Version 1.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2cc2640e9ada
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = tp-kb-backlight-git
+ pkgdesc = Automated keyboard backlight
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/alexmohr/keyboard-backlight
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ makedepends = gcc
+ depends = libinput
+ source = git+https://github.com/alexmohr/keyboard-backlight
+ sha512sums = SKIP
+
+pkgname = tp-kb-backlight-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a4d00c2164b2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Alexander Mohr <keyboard_backlight at mohr dot io>
+
+pkgname=tp-kb-backlight-git
+pkgver=1.0
+pkgrel=1
+pkgdesc='Automated keyboard backlight'
+arch=('x86_64')
+url='https://github.com/alexmohr/keyboard-backlight'
+license=('MIT')
+depends=('libinput')
+makedepends=('git' 'cmake' 'gcc')
+
+source=("git+https://github.com/alexmohr/keyboard-backlight")
+sha512sums=('SKIP')
+
+
+build() {
+ cd "keyboard-backlight"
+ mkdir build -p
+ cd build
+ cmake ..
+ make
+}
+
+package() {
+ appname='keyboard_backlight'
+ install -Dm 755 "keyboard-backlight/build/${appname}" "${pkgdir}/usr/bin/${appname}"
+ install -Dm 644 "keyboard-backlight/keyboard_backlight.service" "${pkgdir}/etc/systemd/system/keyboard_backlight.service"
+
+ echo "Please enable the systemd service via 'sudo systemctl enable --now keyboard_backlight.service"
+ echo "The service file can be used for configuration."
+ echo "See 'keyboard_backlight -h' for options".
+}