summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrederik2017-05-30 18:29:28 +0200
committerfrederik2017-05-30 18:29:28 +0200
commit245e585b9fcbbce008e972a5b142fcf1f23d07e2 (patch)
tree65d3be93a20637ffb97c75686928781f52aa27da
parent6a867f5df4c916ae90c30182cc397a74ab2d2cf0 (diff)
downloadaur-245e585b9fcbbce008e972a5b142fcf1f23d07e2.tar.gz
improve PKGBUILD
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD14
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 86d460be1f20..7c28b4450f30 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Thu Apr 21 16:37:53 UTC 2016
+# Tue May 30 16:29:26 UTC 2017
pkgbase = tpacpi-bat-git
pkgdesc = A Perl script with ACPI calls for recent ThinkPads (such as T420 and W520) whose battery thresholds are not supported by tp_smapi
pkgver = 106.f58e2ae
@@ -14,7 +14,7 @@ pkgbase = tpacpi-bat-git
conflicts = tpacpi-bat
backup = etc/conf.d/tpacpi
source = git://github.com/teleshoes/tpacpi-bat.git
- sha256sums = SKIP
+ sha512sums = SKIP
pkgname = tpacpi-bat-git
diff --git a/PKGBUILD b/PKGBUILD
index d19f28e5fd2e..2e6eb89f53f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,16 +5,16 @@ pkgname=tpacpi-bat-git
pkgver=106.f58e2ae
pkgrel=1
pkgdesc='A Perl script with ACPI calls for recent ThinkPads (such as T420 and W520) whose battery thresholds are not supported by tp_smapi'
+arch=('any')
url='https://github.com/teleshoes/tpacpi-bat'
license=('GPLv3')
-arch=('any')
depends=('perl' 'acpi_call')
makedepends=('git')
-conflicts=('tpacpi-bat')
provides=('tpacpi-bat')
+conflicts=('tpacpi-bat')
backup=('etc/conf.d/tpacpi')
-source=('git://github.com/teleshoes/tpacpi-bat.git')
-sha256sums=('SKIP')
+source=(git://github.com/teleshoes/tpacpi-bat.git)
+sha512sums=('SKIP')
pkgver() {
cd ${pkgname/-git/}
@@ -24,7 +24,7 @@ pkgver() {
package() {
cd ${pkgname/-git/}
- install -Dm755 tpacpi-bat ${pkgdir}/usr/bin/tpacpi-bat
- install -Dm644 examples/systemd_dynamic_threshold/tpacpi.service ${pkgdir}/usr/lib/systemd/system/tpacpi-bat.service
- install -Dm644 examples/systemd_dynamic_threshold/tpacpi.conf.d ${pkgdir}/etc/conf.d/tpacpi
+ install -Dm755 tpacpi-bat "${pkgdir}/usr/bin/tpacpi-bat"
+ install -Dm644 examples/systemd_dynamic_threshold/tpacpi.service "${pkgdir}/usr/lib/systemd/system/tpacpi-bat.service"
+ install -Dm644 examples/systemd_dynamic_threshold/tpacpi.conf.d "${pkgdir}/etc/conf.d/tpacpi"
}