summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrederik2016-04-21 18:38:12 +0200
committerfrederik2016-04-21 18:38:12 +0200
commit6a867f5df4c916ae90c30182cc397a74ab2d2cf0 (patch)
tree187974d712bbb785adfd30023069fb39de563d88
parent8c4279f0906f950cde6bb34c19966c1dd1a7c0af (diff)
downloadaur-6a867f5df4c916ae90c30182cc397a74ab2d2cf0.tar.gz
update PKGBUILD to reflect recent changes
add dynamic setting of threshold via config file
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD41
-rw-r--r--tlp.patch11
3 files changed, 22 insertions, 39 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 330fc157665a..86d460be1f20 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Thu Apr 21 16:37:53 UTC 2016
pkgbase = tpacpi-bat-git
pkgdesc = A Perl script with ACPI calls for recent ThinkPads (such as T420 and W520) whose battery thresholds are not supported by tp_smapi
- pkgver = 94.06ec1d5
+ pkgver = 106.f58e2ae
pkgrel = 1
url = https://github.com/teleshoes/tpacpi-bat
arch = any
@@ -10,10 +12,9 @@ pkgbase = tpacpi-bat-git
depends = acpi_call
provides = tpacpi-bat
conflicts = tpacpi-bat
+ backup = etc/conf.d/tpacpi
source = git://github.com/teleshoes/tpacpi-bat.git
- source = tlp.patch
- md5sums = SKIP
- md5sums = 9799f80a35939a0dd009d05c94418fbf
+ sha256sums = SKIP
pkgname = tpacpi-bat-git
diff --git a/PKGBUILD b/PKGBUILD
index 4dfc7d2b28af..d19f28e5fd2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,36 +2,29 @@
# Contributor: Lucky <archlinux@builds.lucky.li>
pkgname=tpacpi-bat-git
-_pkgname="${pkgname%-*}"
-pkgver=94.06ec1d5
+pkgver=106.f58e2ae
pkgrel=1
-pkgdesc="A Perl script with ACPI calls for recent ThinkPads (such as T420 and W520) whose battery thresholds are not supported by tp_smapi"
-url="https://github.com/teleshoes/tpacpi-bat"
-license=("GPLv3")
-arch=("any")
-depends=("perl" "acpi_call")
-makedepends=("git")
-conflicts=("${_pkgname}")
-provides=("${_pkgname}")
-source=("git://github.com/teleshoes/tpacpi-bat.git"
- "tlp.patch")
-md5sums=("SKIP"
- "9799f80a35939a0dd009d05c94418fbf")
+pkgdesc='A Perl script with ACPI calls for recent ThinkPads (such as T420 and W520) whose battery thresholds are not supported by tp_smapi'
+url='https://github.com/teleshoes/tpacpi-bat'
+license=('GPLv3')
+arch=('any')
+depends=('perl' 'acpi_call')
+makedepends=('git')
+conflicts=('tpacpi-bat')
+provides=('tpacpi-bat')
+backup=('etc/conf.d/tpacpi')
+source=('git://github.com/teleshoes/tpacpi-bat.git')
+sha256sums=('SKIP')
pkgver() {
- cd "${_pkgname}"
+ cd ${pkgname/-git/}
echo $(git rev-list --count master).$(git rev-parse --short master)
}
-
-prepare() {
- cd "${_pkgname}"
-# patch -uNp1 -i "${srcdir}/tlp.patch"
-}
-
package() {
- cd "${_pkgname}"
+ cd ${pkgname/-git/}
- install -Dm755 "${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
- install -Dm644 "${_pkgname%-*}.service" "${pkgdir}/usr/lib/systemd/system/${_pkgname}.service"
+ install -Dm755 tpacpi-bat ${pkgdir}/usr/bin/tpacpi-bat
+ install -Dm644 examples/systemd_dynamic_threshold/tpacpi.service ${pkgdir}/usr/lib/systemd/system/tpacpi-bat.service
+ install -Dm644 examples/systemd_dynamic_threshold/tpacpi.conf.d ${pkgdir}/etc/conf.d/tpacpi
}
diff --git a/tlp.patch b/tlp.patch
deleted file mode 100644
index 36cefa300f1b..000000000000
--- a/tlp.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff --git a/tpacpi.service b/tpacpi.service
-index 4446b70..24ef8d6 100644
---- a/tpacpi.service
-+++ b/tpacpi.service
-@@ -1,5 +1,6 @@
- [Unit]
- Description=sets battery thresholds
-+After=tlp.service
-
- [Service]
- Type=oneshot