summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKaan Genç2015-06-13 14:43:45 +0300
committerKaan Genç2015-06-13 14:43:45 +0300
commit9c968222b72d7113eb2b62dba6fdfc50c99c6885 (patch)
treef7ac69fd1afc4eba97249d1a0a97289d883025b6
downloadaur-9c968222b72d7113eb2b62dba6fdfc50c99c6885.tar.gz
Migrated to AUR4.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD26
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e4db2817626c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = tpl
+ pkgdesc = Efficient serialization in C.
+ pkgver = 1.6.1
+ pkgrel = 1
+ url = https://troydhanson.github.io/tpl/index.html
+ arch = any
+ license = BSD
+ source = https://github.com/troydhanson/tpl/archive/v1.6.1.tar.gz
+ md5sums = e7b294ba0f544e21b450acb0622e180d
+
+pkgname = tpl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3f5b726f3692
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Kaan Genç <SeriousBug at Gmail dot com>
+
+pkgname=tpl
+pkgver=1.6.1
+pkgrel=1
+pkgdesc="Efficient serialization in C."
+arch=(any)
+url="https://troydhanson.github.io/tpl/index.html"
+license=('BSD')
+source=("https://github.com/troydhanson/tpl/archive/v1.6.1.tar.gz")
+md5sums=('e7b294ba0f544e21b450acb0622e180d')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ # Running bootstrap only once causes some files to be left missing
+ ./bootstrap
+ ./bootstrap
+ ./configure --prefix="$pkgdir/usr/"
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+ make install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}