summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormutantmonkey2015-08-16 22:47:46 -0700
committermutantmonkey2015-08-16 22:48:26 -0700
commiteb5f5fd114eb417091869065db89480aa0213a33 (patch)
tree86d3d79c9ef2bd1a9291a9c9512691577c6894b8
downloadaur-eb5f5fd114eb417091869065db89480aa0213a33.tar.gz
Initial upload: tpm-tools 1.3.8-3
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD40
-rw-r--r--no-werror.patch11
3 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df45fe5d8cc7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = tpm-tools
+ pkgdesc = Tools to manage and diagnose a TPM
+ pkgver = 1.3.8
+ pkgrel = 3
+ url = http://sourceforge.net/projects/trousers
+ arch = i686
+ arch = x86_64
+ license = CPL
+ depends = trousers
+ depends = opencryptoki
+ source = http://downloads.sourceforge.net/project/trousers/tpm-tools/1.3.8/tpm-tools-1.3.8.tar.gz
+ source = no-werror.patch
+ sha256sums = 66eb4ff095542403db6b4bd4b574e8a5c08084fe4e9e5aa9a829ee84e20bea83
+ sha256sums = 02c79d976f5d7f783638ec4ce82740ba02f5ea1bb6c45c58bd6ec8de34bc6d2e
+
+pkgname = tpm-tools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b3bef19fb60
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: mutantmonkey <aur@mutantmonkey.in>
+# Contributor: Patryk Kowalczyk <patryk AT kowalczyk dot ws>
+# Contributor: Robert Buhren <robert@robertbuhren.de>
+# Contributor: Gavin Lloyd <gavinhungry@gmail.com>
+# Contributor: xav <xav at ethertricks dot net>
+# Contributor: julian <pidanc_j at epita dot fr>
+
+pkgname=tpm-tools
+pkgver=1.3.8
+pkgrel=3
+pkgdesc="Tools to manage and diagnose a TPM"
+arch=('i686' 'x86_64')
+url="http://sourceforge.net/projects/trousers"
+license=('CPL')
+depends=('trousers' 'opencryptoki')
+source=(http://downloads.sourceforge.net/project/trousers/${pkgname}/${pkgver}/${pkgname}-${pkgver}.tar.gz
+ 'no-werror.patch')
+sha256sums=('66eb4ff095542403db6b4bd4b574e8a5c08084fe4e9e5aa9a829ee84e20bea83'
+ '02c79d976f5d7f783638ec4ce82740ba02f5ea1bb6c45c58bd6ec8de34bc6d2e')
+
+prepare() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ patch -N -p1 -i ../no-werror.patch
+}
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --enable-static \
+ --sbindir=/usr/bin
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make DESTDIR=${pkgdir} install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/no-werror.patch b/no-werror.patch
new file mode 100644
index 000000000000..711d8670cf56
--- /dev/null
+++ b/no-werror.patch
@@ -0,0 +1,11 @@
+--- tpm-tools-1.3.7/configure 2011-09-07 16:48:29.000000000 +0200
++++ tpm-tools-1.3.7_NEW/configure 2012-01-06 14:59:52.970136356 +0100
+@@ -13037,7 +13037,7 @@
+ fi
+
+
+-CFLAGS="$CFLAGS -Wall -Werror -Wreturn-type -Wsign-compare"
++CFLAGS="$CFLAGS -Wall -Wreturn-type -Wsign-compare"
+
+ ac_config_files="$ac_config_files ./Makefile po/Makefile.in m4/Makefile include/Makefile lib/Makefile src/Makefile src/tpm_mgmt/Makefile src/cmds/Makefile src/data_mgmt/Makefile dist/tpm-tools.spec man/Makefile man/man1/Makefile man/man3/Makefile man/man8/Makefile"
+